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Introduction
Welcome to the Analyze 12.0 Essential Training Guide. This document provides an overview of Analyze 12.0 core functionality through 
exercises that guide new users step-by-step through basic and advanced Analyze procedures. A fully comprehensive overview of all Analyze 
12.0 module functionality can be found in the User’s Guide and Tutorials located under the Help menu within the software. If you have not 
installed Analyze 12.0, please refer to the Analyze 12.0 Installation Instructions provided with the software.

Installing Tutorial Data

In order to work through the Essential Training Guide exercises 
and Analyze Tutorials, you need to install the tutorial data from the 
Resources CD. To install the tutorial data:

1.	 Insert the Analyze Resources CD into your computer.

2.	 Open Analyze 12.0 and choose Help > Tutorials.

3.	 Click Install Tutorial Data at the bottom of the Tutorials 
window. Note, if the tutorial data has already been insatlled 
this button will not appear.

4.	 In the window returned, specify the path to the tutorial data, 
for example D:\TutorialData (where D:\ is equal to your CD-
ROM drive)

5.	 Click Install. All of the tutorial data will be copied from the 
Resources disk to the $:\BIR\images\TutorialData folder 
(where $ is the install directory, e.g. C:\ on a windows 
system).

Quick Reference

Button Reference: Displays PowerBar button or tool button 
referenced in that exercise step. The button will be next to the step 
that it refers to. Often, the step only mentions the file path, but the 
button is displayed as a shortcut. Example:

Open the DICOM Tool (File > DICOM Tool).
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Analyze Basics
The Main Analyze Window

The main Analyze window is the first operational 
window that appears when Analyze is opened. The 
main Analyze window does not perform any imaging 
functions, but it does coordinate all the modules 
within the Analyze package and acts as a file 
manager for loaded data. It consists of three major 
components: the Analyze workspace, where all of the 
loaded data, represented as icons, are managed; the 
Analyze menu, where individual Analyze modules are 
selected; and the Analyze PowerBar, which provides 
icon-based shortcuts to the most frequently used 
Analyze modules.

Loading Data into Analyze

Image data is loaded into Analyze using one of the load modules 
(Load, Load As, DICOM Tool, or Import/Export) from the ‘File’ menu 
in the main Analyze window. Most of the individual Analyze modules 
also support data loading directly within the module (File > Load 
within the module).

To load DICOM data, use the DICOM module; for more information 
on how to use this module, please refer to Exercises 1-2 of this 
Guide.

To load all other data into Analyze, refer to Exercises 3-6 of this 
Guide.

The tutorial data used in the Essential Training Guide exercises can 
be loaded into Analyze using the Load module (File > Load). It is 
assumed that the data was installed to $:\BIR\images\TutorialData 
(where $ is the install directory, e.g. C:\ on a Windows system) 
according to the “Installing Tutorial Data” instructions on page 6.

Analyze Menu

Power Bar
Tabbed Analyze 

Workspace

Image Data Icon
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Analyze Basics
The Analyze Workspace

Once data is loaded into Analyze it will appear as an icon in the Analyze workspace and is available to all of the modules in the Analyze 
package. To load data into a module, select the image icon in the Analyze workspace (the icon will appear framed in red when selected) and 
open the desired module from the Analyze menu or PowerBar. If multiple icons are selected at the time the module is opened, one of the two 
actions will occur:

1.	 If the opened module supports or requires multiple volumes, the volumes are used in the order selected.

2.	 If multiple loaded volumes are not supported, then multiple instances of the module are invoked.

Right Mouse Button Menu

The Analyze workspace is an area with additional options. When the right 
mouse button is clicked in the workspace, a menu will appear. The menu 
provides the following options:

•	 Unload: Unload selected data from the Analyze workspace

•	 Info: Display the header information for a selected data set

•	 Rename: Change the name of a selected data set

•	 Edit Header: Modify the header information of a selected data set

•	 Append: Append selected data

•	 Unappend: Unappend 4D multi-volume data sets, or RGB data sets

•	 Select All: Select all data sets in the Analyze workspace

•	 Invert Selected: Invert your selection of data in the Analyze 
workspace

•	 Arrange: Arrange data sets by Name, Size or Modify Time

•	 Current Directory: View and modify the Current Directory location

•	 Workspace Directory: View and modify the Workspace Directory 
Location

•	 Session Log: Stores information that might be useful to the Analyze 
support team and software developers, should a problem ever arise 
with one of the modules.

Main Analyze Window Quick Keys

•	 <Ctrl><a> Selects all of the files in the workspace.

•	 <Shift><Left Mouse Click> Selects all files between 
first and shifted selections.

•	 Double clicking on a data set in the workspace restarts 
the last module used with that data. If there is not 
a module associated with the data, the Multiplanar 
Sections module will open by default.
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Analyze Basics
The Analyze Menu

The File menu contains the modules that are used to input and output data, as well as the standard ‘Save’, ‘Save As’ and ‘Exit’ options.

Display

Multiplanar Sections
Oblique Sections
Volume Compare
Volume Render
Surface Render
Virtual Endoscopy
Movie

Process

Image Calculator
Image Algebra
Image Repair
Histogram Ops
Spatial Filters
Filter Designer
3-D FFT

Segment

Image Edit
Volume Edit
Morphology
Watershed
Multispectral Classification
Object Extractor
Surface Extractor

Register

2-D Registration
2-D Non-rigid Registration
Point to Surface
3-D Surface Registration
3-D Voxel Registration
3-D Non-rigid Registration

Measure 

Line Profile
Region of Interest
Stereology
Object Counter
Tree Analysis

Apps

SISCOM
Mayo 3-D Brain Atlas*
DTI*
BMA*
T2 Projection*
Volume Metrics*

*These modules require the purchase of an additional license
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Analyze Basics
The Analyze Menu

Additional items available in the Analyze menu include:

The Other menu contains utilities and modules for configuration and resource monitoring.

•	 Resources: The Resource Monitor assists in maintaining 
system resources at a level that does not impede proper 
execution of Analyze. The resources being monitored and 
displayed are Swap space, Workspace, and user specified 
directory Disk space. For all three, the Resource Monitor 
reports the amount of space used, space available or free, 
and total capacity.

•	 PowerBar Editor: the PowerBar Editor is an option that 
appears in all Analyze modules that contain PowerBar 
options. 

•	 Options: The Options item allows you to switch on and off 
workspace features such as the PowerBar, and the pop-
up icon names which are shown when the mouse cursor 
is moved over an image in the workspace. You can also 
configure Add-On modules to be switched on or off.

•	 AppDefaults Editor: The AppDefaults Editor provides 
several tools for managing and changing defaults or 
user preferences for the Analyze workspace and specific 
Analyze modules. For further information about the 
AppDefaults Editor please reference the User’s Guide 
(Help > User’s Guide).

The Help menu provides access to several important Analyze 
resources:

•	 User’s Guide: Provides detailed information on each 
Analyze module.

•	 Tip of the Day: Can be set to display an Analyze “tip” 
each time Analyze is opened.

•	 Tutorials: Tutorial exercises covering some of the main 
Analyze functions. Note, you must have selected to install 
the Tutorials during initial Analyze installation.

•	 Analyze Update: Checks to make sure Analyze is up-
to-date, also will download and install any necessary 
updates.

•	 Online Support: Provides a direct link to the AnalyzeDirect 
Support home page.

•	 Analyze Demos: Provides a direct link to a list of Help 
Movies

•	 Copyrights: Documentation of Analyze Copyrights.

•	 About: Provides version, system, and environment 
information.
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Analyze Basics
Main Analyze PowerBar

Directly below the menu bar in the main Analyze window you will find the 
PowerBar of icons. The icons on this main Analyze PowerBar provide 
shortcuts to the most commonly used Analyze modules. By default, the 
main Analyze PowerBar contains icons for:

Load As, DICOM Tool, Multiplanar Sections, Oblique Sections, Volume Render, Movie, Volume 
Edit, 3D Voxel Registration, Region of Interest, and Exit.

Module-Specific PowerBars

In addition to the main Analyze window, you can also find a PowerBar in each Analyze module. The icons included on the PowerBar of 
each Analyze module provide shortcuts to the most commonly used tools and options within that specific module.

PowerBar Editor - Customizing PowerBars

Customizing Analyze PowerBars is a quick and easy way to streamline your work flows and routine processes. To customize the 
PowerBar displayed within any Analyze window, you can use the PowerBar Editor found under the window’s ‘Other’ menu (Other > 
PowerBar Editor).

Using the PowerBar Editor, you can:

•	 Add/Remove PowerBar icons: To add an icon to the PowerBar, select it in the PowerBar Editor list (selected icons appear 
highlighted in black). To remove an icon, deselect it in the PowerBar Editor list.

•	 Change the order of PowerBar icons: With the PowerBar Editor open, drag-and-drop an icon on the PowerBar to a new 
location.

•	 Create additional PowerBars: To create multiple PowerBars for the main Analyze window or an Analyze module, click the New 
button in the PowerBar Editor and then select the desired icons for the new PowerBar. You can scroll through the PowerBars using 
the up/down arrow buttons added to the far left of the PowerBar.

•	 Be sure to press Save in the PowerBar Editor if you wish to keep your PowerBar changes for future sessions. Otherwise, changes 
will be lost upon exiting the Analyze module, or Analyze.
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Loading Data into Analyze
Analyze 12.0: Essential Training Guide
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The DICOM Tool expands DICOM support in Analyze, enabling the indexing of collections of DICOM images through a local database file. 
This exercise will demonstrate how to create a database and then how to import DICOM data into the database. Note: If you are a previous 
BirPacs user please contact support@analyzedirect.com for instructions on migrating your database to the DICOM Tool.

1.	 Open the DICOM Tool (File > DICOM Tool).

2.	 The DICOM Tool will detect that there is no database present; a dialog box 
will be returned asking you if you would like to create a new database or 
browse for an existing database, click Create a new local database.

3.	 The Create New Image Database window (Figure 1) allows you to 
specify a database name and file system directory, configure a DICOM 
receiver for the database (optional), configure a database server (optional), 
and specify the source of initial DICOM images (optional).

4.	 The Local Database Name will default to ‘SystemName_PortNumber’; 
change the Local Database Name to TEST_5679.

5.	 On your system’s local disk create a folder called ‘AnalyzeDB’  
($:/AnalyzeDB)

6.	 Click the Local Database Directory button in the Create New Image 
Database window.

7.	 In the Browse for Folder window returned navigate to the location of the 
new ‘AnalyzeDB’ folder ($:/AnalyzeDB), select the folder, and click OK. 
You have now specified the location of your local database.

8.	 To create the local database click the Create Local Database button.

Figure 1

note If this is not the first time you have accessed the DICOM Tool, you can access the
Create New Image Database window by selecting File > Create Database.

Exercise 1DICOM Tool: Quick Configuration
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DICOM Tool: Quick Configuration
9.	 Once the database has been created a dialog box will be 

returned stating ‘All Done’, click OK. 

10.	 To import DICOM data into the DICOM Tool right-click 
anywhere in the white space and select Import DICOM 
Images from the menu (Figure 2). Alternatively, select File > 
Import DICOM Images.

11.	 In the (Browse for Folder) window returned navigate 
to and select the folder $:\BIR\images\TutorialData\
ImportExportTutorial, then click OK.

12.	 A dialog box will be returned asking you to confirm that you 
would like to ‘Import all DICOM files found below <C:/BIR/
images/TutorialData/ImportExportTutorial>’, click Yes to 
confirm.

13.	 All 121 DICOM images contained within the folder will be 
copied into the database. The DICOM Tool will automatically 
sort and index the data by patient, study, series, and volume.

14.	 Data can be selected and viewed in the DICOM Tool (Figure 
3). To load a selected data set into the Analyze workspace 
click Load Volume; if you wish to resize or resample the data 
click Load As, this will load the selected data into the Load 
As module (see exercise 4 for instructions on how to use the 
Load As module).

Figure 2

Figure 3

Exercise 1
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Exercise 2

The DICOM Tool expands DICOM support in Analyze, enabling the indexing of collections of DICOM images through a local database file. With the 
DICOM Tool, databases can be created, updated, and shared with other users with file system access to the images and the database file. This 
exercise will demonstrate how to create a database, configure a DICOM receiver and Database sender and then how to import DICOM data into 
the database. Note: If you are a previous BirPacs user please contact support@analyzedirect.com for instructions on migrating your database to the DICOM Tool.

1.	 Open the DICOM Tool (File > DICOM Tool).

2.	 If you have already completed Exercise 1, choose File > Create Database. If the 
DICOM Tool detects that no database is present, a dialog box will be returned 
asking you if you would like to create a new database or browse for an existing 
database, click Create a new local database.

Specification of the Database Name and Directory

3.	 In the Create New Image Database window you can specify the database name 
and file system directory, specify a DICOM receiver for the database (optional), 
specify database server (optional), and specify the source of initial DICOM images 
(optional).

4.	 The Local Database Name will default to ‘SystemName_PortNumber’; change the 
Local Database Name to TEST2_5679. 
 

 
 

5.	 The Local Database Directory option enables you to specify the directory on your 
system in which the database and all of the DICOM images will be stored.

i.	 On your system’s local disk create a folder called ‘AnalyzeDB’ 
($:/AnalyzeDB). Note that if you have completed exercise 1, DICOM Tool - 
Quick Configuration, this folder should already exist.

ii.	 Once the directory has been created, click Local Database Directory in the 
Create New Image Database window, and navigate to the location of the new 
‘AnalyzeDB’ folder ($:/AnalyzeDB).

iii.	 Select the folder and click OK. You have now specified the location of your 
database. Figure 1

note Any name can be chosen for the local database, however when creating multiple databases, 
following a coherent naming convention will simplify database management.

DICOM Tool: Advanced
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Specification of a DICOM Receiver (optional)

6.	 The Configure DICOM Receiver option allows you to configure a 
DICOM receiver for the database. This step is optional, if you do not 
want to configure the receiver please move on to step 8, otherwise 
check the Configure DICOM Receiver option.

7.	 DICOM Receiver configuration requires three key pieces of information: 
the Receiver AET, the Receiver Port on the local system, and the 
directory where the DCMTK executable programs are installed.

i.	 DICOM Receiver AET: By default is set to ‘SystemName_
PortNumber’. To reflect the receiver’s connection to the database 
defined in step 4, change the DICOM Receiver AET to TEST2_5679.

ii.	 DICOM Receiver Port: Specifies the TCP/IP port number on which 
the DICOM Receiver listens for connections to receive messages. 
For this exercise, the DICOM Receiver Port can remain 5679.

iii.	 DCMTK Path: The DCMTK executable files are automatically 
installed with Analyze in the $:\BIR\DCMTK-3.5.4\$System_Type$\
bin directory (where $System_Type$ is your system platform, e.g. 
PC_NT) and the DCMTK Path will point to this directory by default. 
However, if Analyze is being run from a network rather than local 
installation, the DCMTK files should be installed locally and this 
path should point there.

DICOM Tool: Advanced Exercise 2
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Specification of a Database Server (optional)

8.	 The Configure Database Server option allows you to configure an optional 
database server to manage automatic updates and multiple client access to 
the database over a network. The database server is a dedicated process 
attached to one database and accessible by system name and port 
number. It responds to connection requests, SQL statements, and requests 
for images, and polls the image storage area for newly received images 
to register. Configuring and installing a database server is very similar to 
configuring the DICOM receiver. This step is optional, if you do not want to 
configure the database server please move on to step 10, otherwise check 
the Configure Database Server option.

9.	 The Database Server fields are used to configure the database server 
process that controls access to the database.

i.	 Service Name: The name by which the servicer is identified, for this 
exercise use TEST2_5679. 
 

ii.	 Host System: Identifies the system name this program is running on. 
You can create servers to run on your system, and any server should be 
attached to a database local file system.

iii.	 Port Number: Specifies the port number client systems will use to 
connect to server. It cannot be the same port as the one used by the 
DICOM receiver (STORESCP). For this exercise set the port to 5680.

iv.	 Update Frequency: Specifies the interval in minutes at which the server 
will poll the image storage directory to see if the DICOM receiver has 
deposited images to be in the database. For this exercise, you can leave 
this set to 5.

v.	 Server Logging: Creates a log file of the database server for diagnostics.
tip It is recommend using a closely related 

port number so they can be easily re-
membered; e.g., if the receiver is running 
at port n, run that database server at 
port n+1.

note On Windows systems this becomes the name of the Windows Service; on UNIX sys-
tems it is used to name the daemon script which starts, stops and checks server status.

DICOM Tool: Advanced Exercise 2
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Specification of the Source of Initial Images (optional)

10.	 The Source of Initial Images option allows you to specify a directory 
containing DICOM images; click Source of Initial Images.

11.   In the Browse for Folder window returned, navigate to the $:\BIR\images\
TutorialData directory, select the ImportExportTutorial folder, and click OK.

Creating the Database Server

12.	 To create the local database, click Create Database Server.  
Note, creating a Database Server requires administrative privileges;  
a dialog box will automatically be returned stating that you will  
receive a prompt from your operating system, click OK. You will  
then need to enter the administrator password.

13.	 The DICOM Tool will now copy the DICOM images from the initial 
source to the location (if selected) specified in step 5. The data will 
automatically be sorted and indexed by patient, study, series, and 
volume.

14.	 Once the process is complete, the Create New Image Database 
window will automatically be dismissed and the data will now be 
available in the DICOM Tool (figure 2).

Viewing and Loading Data

15.	 Data can be selected from the Patient information panel in the 
DICOM Tool.

16.	 Select the data set with the ‘Patient Name’ MR SIGNA LX 1.0T 
and ‘Patient ID’ 337. The data set will be highlighted, note the 
other information panels will automatically update with relevant 
Study, Series, and Volume information (when available).

17.	 Note there are two data sets available for selection in the Series 
information panel below. Select Series 102.

Figure 2

DICOM Tool: Advanced Exercise 2
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18.	 Review the data slice-by-slice by using the Slice Number slider bar under the 
image display.

19.	 Right-click on the image display to open the Intensity window (figure 3). Here 
you can change the intensity display of the image; use the slider bar to take 
the Maximum intensity level down to 500. The image display will interactively 
update. Click Done to dismiss the Intensity window.

20.	 To load this data set into the Analyze workspace, click Load Volume. The data 
set will automatically load into the Analyze workspace.

Other DICOM Tool Options

21.	 Move the cursor over any of the information panels and right-click. The menu 
returned provides most of the options available for management of the images 
in the DICOM database, these options include:

Refresh: Deselects any selected data and refreshes the data
Configure Columns: Configure the column properties for the data display
Configure Search: Focus the scope of the displayed data with an 

information search
Show Server Info: Enable/disable display of recent databases and remote 

AETs
Update DB: Register any recently received unregistered images in the 

database
Query Current AET: Perform query retrieve on remote AET to retrieve 

images
DB Update Status: Enable/disable display of Database Update Status
Import DICOM Images: Copy and register images from the file system to 

the database
Load Patient: Load patient data from files
Export Patient: Export patient data to files
Delete Patient: Delete the patient data from the database
Send Patient: Send patient data to listening server
Anonymize Patient: Anonymize the patient information (only available from 

the patient pane)

Figure 3

note If you wish to resize or resample the data use 
the Load As button option, this will load the 
selected data into the Load As module (see 
exercise 4 for instructions on how to use the 
Load As module).

DICOM Tool: Advanced Exercise 2
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22.	 On your system’s local disk create a folder called ‘test_
export’ ($:/test_export).

23.	 Select the ‘Patient Name’ MR dataset Brain and then right-
click and select the Export Patient option (figure 4).

24.	 In the (Browse for Folder) window returned, navigate to the 
new ‘test_export’ directory, then click OK. The DICOM 
images will be exported out to this directory.

25.	 Now navigate to the ‘test_export’ directory on your 
system’s local disk; note the file names have changed to 
new DICOM UIDs.

26.	 In the DICOM Tool, with MR data set Brain still selected, 
right-click and select the Delete Patient option.

27.	 A dialog box will be returned asking you to confirm that this 
is what you want to do, click Yes. A delete confirmation 
window will be returned, click OK to dismiss it.

28.	 To import this data back into the DICOM Tool right-click in 
any of the information panels and select the Import DICOM 
Images option. In the window returned navigate to and 
select the ‘test_export’ directory on your system disk, then 
click OK.

29.	 You will be asked if you would like to ‘Import all DICOM 
files found below <$:/test_export >’, click Yes to import 
these images back into the database. The data will be 
automatically sorted and imported into the DICOM Tool 
database, and the data set will appear in the Patient 
information panel.

30.	 Close the DICOM module before proceeding to the next 
exercise.

tip

Figure 4

Multiple databases can be created for the DICOM Tool, so multiple 
DICOM receivers can be configured for the tool; you can select different 
databases from the Local Databases drop-down menu option.

DICOM Tool: Advanced Exercise 2
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Switching on Support for Additional Formats Exercise 3

Analyze supports over 45 different file formats. By default, only the most common formats are enabled. The Import/Export module’s External 
Libraries tool can be used to enable and disable these formats. This exercise will show you how to use the External Libraries tool to switch on 
support for additional formats.

1.	 Open the Import/Export module (File > Import/Export).

2.	 To view the file formats currently supported in Analyze, choose Help > 
Formats.

3.	 File formats currently supported are listed in the bottom ‘Formats’ 
section of the Supported Formats window (figure 1). When a format is 
selected, the associated properties will automatically become checked in 
the ‘Properties’ section of the window. Experiment by checking several 
different formats and noting their properties. Click Done to dismiss the 
window.

4.	 Open the External Libraries tool (Tools > External Libraries).

5.	 The External Libraries tool provides a graphical interface listing all formats 
supported by Analyze (figure 2). The green and red status indicators note 
whether a format is currently ‘Loaded’ (L) and ‘Configured’ (C) - green 
indicating yes and red indicating no.

6.	 If you wish to switch on support for a specific file format (for example, 
PICKERMRI), click on the format in the External Libraries tool. A Configure 
‘X’ Format window will be returned (where ‘X’ is equal to the selected 
format) (figure 3).

7.	 In the Configure ‘X’ Format window, click Load Now to change the  
‘Currently Loaded’ status to a green Yes.

Figure 2

Figure 3

Figure 1

note Users running multiple operating systems need to configure support for each file 
format for each operating system. The ‘Platforms’ option allows the format to be con-
figured for all operating systems (ALL) or for a specific operating system (SPECIFIED).
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Switching on Support for Additional Formats
8.	 Click OK. A dialog box will be returned stating that your ‘EXTEND.conf’ file will 

be updated, click OK (figure 4). The format is now supported by Analyze.

9.	 If you would like to load and configure all supported formats for your system, 
click Max in the External Libraries tool. All image file formats will now be 
supported by Analyze. The ‘L’ and ‘C’ status indicators will appear green next 
time you open Import/Export and the External Libraries tool (figure 5). 
 

 
 
 

10.	 Click Done to close the External Libraries tool.

11.	 Close the Import/Export module before proceeding to the next exercise.

note Each file format enabled increases the amount of memory used by your system; it
also increases the time taken for a module to open. However, this is typically only
an issue on older systems or systems where memory resources are scarce.

Figure 5

Figure 4

Exercise 3
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Supported File Formats

Analyze

AnalyzeAVW 	 used internally for memory mapping, 			 
		  supports all data types, 2D, 3D, and 4D.
UNKNOWN	 enables reading raw binary data into images, 		
		  and exporting image data as raw.
Volume File	 enables lists of 2D files to be used as 3D entity
OBJMAP	 enables object maps to be treated as regular imgs
AnalyzeImg	 old Analyze 7.5 format, i.e. .hdr/.img pairs
AnalyzeScrn	 old Analyze 7.5 format of old Screen Edit program

Raster

BMP 		  Microsoft Windows Bitmap
GIF 		  a common color indexed format
JPG 		  common format featuring lossy compression
PBM		  ascii and binary formats used in Portable Bitmap
		  Library
PGM 		  grayscale Portable Bitmap Library
PPM 		  24 bit Color Portable Bitmap Library
PIC 		  format used by Softimage
PNG 		  Portable Network Graphics
PS 		  output to a PostScript raster dump
SGI 		  format used by Silicon Graphics
SUNRASTER 	format used by Sun Microsystems
TARGA 	 a common color format
TIFF 		  tagged information file format, a common format
XBM 		  an ascii ‘c programming language’ format used by 		
		  the X Windows system
XWD X 	 Windows dump

Standard Radiological File Formats

DICOM 		  the standard medical image file format based on
			   Mallincrodt ctn_3_0_3.
ACR/NEMA 		  precursor to DICOM
PAPYRUS2 3D 	 extensions to DICOM from OSIRIS
PAPYRUS3 3D 	 extensions to DICOM from OSIRIS
NIfTI 			   Neuroimaging file format

Video

QUICKTIME 		  common movie format
YUV 			   single frame color video format
AVI 			   video format used by Microsoft Windows
MPEG1 		  standard movie format

Vendor-Specific Radiological File Formats

GE9800 		  older CT format
GEADVANCE 		 Advance, nulcear medicine format
GEADVANTAGE 	 format for CT and MRI
GESIGNA 		  older MRI format Signa 4.x
GESTARCAM 		 older PET format
INTERFILE 		  a standard format for nuclear medicine
PICKER MRI 		  old MRI format used by Picker
SIEMENSCT 		  old Siemens CT format Somatom DR3
SIEMENSMAGVIS 	 Siemens Magnetom Vision (MRI format)
CTI 			   PET format used by CTI, early version of ECAT7
7CTI 			   PET format used by CTI; CTIECAT7
IMATRON 		  proprietary CT format
SMIS 			   proprietary MRI format
BRUCKER MRI 	 proprietary MRI format
BIO RAD 		  proprietary format
VARIAN FDF 		  Varian MRI format
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Load As: Loading & Resizing Anisotropic Data Exercise 4

Scanner acquired data is rarely isotropic (cubic) which means that the voxel width, height, and/or depth have different sizes (most often a 
different slice thickness than the in-plane resolution). This exercise will demonstrate how to load an anisotropic (non-cubic) volume image 
with the same resolution as when acquired, and then load it again to resize the volume image to create an isotropically sampled volume 
(cubic) for further use in Analyze.

1.	 Open the Load As module (File > Load As).

2.	 Click File and navigate to and select the MRI_Head.avw data set in the  
$:\BIR\images\TutorialData directory.

3.	 Uncheck the Auto Exit After Load option and click Load. The data will be 
loaded into the Analyze workspace as it was acquired (anisotropic).

4.	 To load the data as isotropic (cubic), select the Resize tab (figure 1).

5.	 Check the Force Cubic option and click Load; Select ‘Create New’ and the 
data will be resampled at the cubic resolution and then loaded. The highest 
spatial resolution in the acquired volume image is used as the cubic resolution 
for resampling.

6.	 Two volumes are now loaded into the Analyze workspace, ‘MRI_Head’ and 
‘MRI_Head0’. The latter volume is the cubic volume. To examine the effects of 
this isotropic sampling, proceed to Exercise 8: Multiplanar Sections.

7.	 If a specific cubic voxel resolution is desired, the voxel size can be changed. To 
set the output voxel dimension to 1.5 mm, enter 1.5 in the Output Voxel Size 
field and press <Enter>. Notice that the ‘Output Axis Dimensions’ and ‘Memory’ 
fields automatically adjust when the voxel dimension is changed.

8.	 It is also possible to set a specific dimension for the resulting volume image.  
For example, if you wanted an output volume with an X dimension of 200, enter 200 in 
the Output X Axis Dimension field and press <Enter>. Again, the other parameters will 
automatically adjust.

9.	 You may encounter data sets that are too large to be accommodated by the computer on 
which you are running (usually due to memory limitations), particularly at the resampled cubic 
resolution. Specifying a maximum memory size while the Force Cubic option is checked forces 
each parameter to adjust to the largest value possible that still fits within the specified memory 
size. Enter 16 into the Output Memory Mb field [G].

10.	 Close all windows related to the Load As module before proceeding to the next exercise.

Figure 1
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Import/Export: Converting Raw Data to Images Exercise 5

Occasionally it is necessary to import raw data or image data of an unknown file format into Analyze. Such data can be imported if pixels are 
uncompressed and in contiguous images within the file. The Raw Data tool provides several interactive options to view data as images, ASCII 
strings, or as the actual binary values of bytes and words. Data can be directly loaded into Analyze or converted into Analyze format image 
files. Most image file formats consist of some initial header information describing the image(s) and the actual image data. This exercise will 
demonstrate how to convert raw data from a scanner, which currently has no direct file format support in Analyze.

1.	 Open the Import/Export module (File > Import/Export).

2.	 Open the Raw Data tool (Tools > Raw Data).

3.	 With the Files tab selected, click the File button under ‘Input’ (figure 1).

4.	 In the Import/Export – Input File window returned navigate to the $:\BIR\ images\
TutorialData\ImportExportTutorial directory and select the file 
UNKNOWN1.

5.	 Select the Image Parameters tab (figure 2).

6.	 For this exercise, assume that we know that this file contains one 256 
x 256 image, a signed 16-bit integer. An image of this size requires 
131072 bytes of storage (256 x 256 x 2), however the file size is 137210 
bytes. This indicates that there is an additional 6138 bytes of header 
information present. This needs to be skipped to get to the first byte 
of image data. Finally, we know that the 16-bit image data in the file is 
stored in Big-Endian byte format.

7.	 To accommodate this, set the following parameters:

•	 Byte Offset: 6138  (or check ‘Auto Offset’ to compute this 
automatically)

•	 Width: 256 

•	 Height: 256 

•	 Data Type: signed 16-bit 

•	 Byte Swap: Pairs (this only needs to be set on a little-endian  
architecture, i.e., PC-based systems) 

Figure 1

Figure 2
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8.	 Check the following Auto options:

•	 Display: Image display will update anytime a control parameter 
is changed.

•	 Clear: Image display is cleared before a new image is displayed.

•	 Scale: Data is automatically scaled from its entire dynamic 
range to 8-bits for display.

9.	 Click Display to view the current image in the main Import/Export 
window (figure 3).

10.	 Click Load in the Raw Data tool to load the image specified in the 
file into the Analyze workspace.

11.	 Experiment with the display effects by changing the image 
parameters to incorrect values, use the up and down arrow buttons 
found next to the Width and Height fields.

12.	 Click Done to close the Raw Data tool.

Figure 3

Import/Export: Converting Raw Data to Images Exercise 5
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Import/Export: Volume Tool Exercise 6

Most medical image formats do not support 3-D directly, since each slice in a study is written to a separate file. The Volume Tool provides a way to 
create a pseudo format for handling groups of 2-D files as a single 3-D entity. Analyze uses the AVW_VolumeFile, or volume file (.vol), as a way to 
organize a list of 2-D files into a 3-D volume. The files must contain images of the same size and data type. This exercise will show you how to use 
the Volume Tool to create a volume file from a list of 2-D TIFF files.

1.	 Open the Import/Export module (File > Import/Export).

2.	 Open the Volume Tool (Tools > Volume Tool).

3.	 In the Volume Tool, click Wild Cards.

4.	 In the window returned (figure 1), click Directory and navigate to $:\BIR\
images\ TutorialData\VolumeToolTutorial - the directory containing the 2-D 
TIFF data for this exercise.

5.	 The Filter field is set to * by default so everything in the directory is selected. 
As this directory only contains TIFF data specific to the data set we wish to 
load, leave the filter as is.

6.	 Click Apply. The TIFF files will now be copied to the Volume Tool  
(figure 2).

7.	 In the Volume Tool, click Verify to ensure that all the slices selected are the 
same size and data type.

8.	 A dialog box (figure 3) will be returned upon successful verification stating 
‘Verify Succeeds’; click Continue.

9.	 Click Save and save the volume file as TIFF_Head.vol in the $:\BIR\images\
TutorialData directory.

10.	 Close the Import/Export module before proceeding to the 
next exercise.

Figure 1

Figure 2Figure 3
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Saving Data Out of Analyze Exercise 7

At some point it will become necessary for you to save your data out of Analyze. This exercise will demonstrate how to do this using 
the Save module.

1.	 Select a data set from the Analyze workspace. If there is no data loaded, load 
MRI_3D_Head.avw from the $:\BIR\images\TutorialData directory.

2.	 Open the Save module (File > Save).

3.	 Click File and navigate to the directory where you would like to save the data 
set and specify a name. Click Save to return to the main module window.

4.	 Use the Format drop-down menu to specify the format in which you wish to 
save the data set.

5.	 Click Save to save the data set and close the Save module.

Figure 1

note

tip

Only formats enabled in the external libraries tool will be available. To switch on support for 
additional formats, please refer to Exercise 3: Switching on Support for Additional Formats.

You can also save your data out of Analyze us-
ing the Save As module. The Save As module 
provides the same tools as the Load As mod-
ule, allowing you to resize, change orientation, 
sub-region, and perform other manipulations 
on your data while saving it out of Analyze.
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Display and Visualization
Analyze 12.0: Essential Training Guide



Analyze 12.0 Training Guide 28

Multiplanar Sections Exercise 8

The Multiplanar Sections module allows the user to quickly and easily view image data in the plane of acquisition or in any naturally orthogonal 
plane. The module contains several tools for easy two-dimensional display, and has the capacity to load volumes, load object maps, select 
orthogonal orientations, and perform intensity windowing or thresholding.

1.	 Load the MRI_Head.avw data set from the $:\BIR\images\TutorialData  
directory. The data set may already be available in the Analyze workspace if 
you have completed Exercise 4: Loading and Resizing Anisotropic Data.

2.	 Open the Multiplanar Sections module (Display > Multiplanar Sections).

3.	 Press the Display Section(s) PowerBar button or choose Generate > Display 
Section(s). This will begin a sequential display of the data, the display may 
be stopped at any time by clicking anywhere in the main Multiplanar Sections 
window (figure 1).

4.	 Since MRI_Head.avw was acquired in the sagittal orientation, this is the 
default orientation for display purposes. The display orientation can be 
changed to display images in a transverse, coronal, or sagittal orientation. Use 
the Orientation PowerBar buttons to change the display orientation or open 
the Orientation window (Generate > Orientation).

5.	 To specify a particular slice to view or to begin the sequential display from, 
open the Slice window (Generate > Slice). Use the ‘Slice’ slider bar to set the 
specific slice.

Scan Tool

6.	 The Scan Tool (Tools > Scan) provides an interface for slice-by-slice review. 
Click either of the green ‘play’ arrows to start a sequential display of slices, or 
use the + and - buttons to move one slice at a time. The slider bar can also be 
used to move through the slices.

Figure 1

notetip Since MRI_Head.avw is anisotropic, images will 
appear “squashed” in the coronal and transverse 
orientations. The resized data set MRI_Head0 
created in exercise 4, Loading and Resizing 
Anisotropic data, will display normally in all three 
orientations.

The Slice window also contains three display options: Continuous, 
Single Step, and Page Mode. ‘Continuous’ sets the display mode to 
display the slices in a continuous stream. ‘Single Step’ turns off the 
continuous display of slices, when Display Section(s) is selected only 
one slice is displayed. ‘Page Mode’ sets the display mode to display a 
page of slices at a time when Display Section(s) is selected.
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Multiplanar Sections
Intersecting Sections Tool

7.	 Open the Intersecting Sections tool (Tools > Intersecting Sections). The 
Intersecting Sections tool provides an interactive display of intersecting 
orthogonal sections.

8.	 To change the angle at which the intersecting sections are viewed, use the 
View Angle X, Y, and Z slider bars. The view angle can also be changed by 
clicking in the image display and dragging the image to a new view.

9.	 Use the Slice X, Y, and Z slider bars to manipulate the intersecting 
orthogonal sections. The ‘X’ slider bar controls the sagittal slice displayed, 
‘Y’ the coronal, and ‘Z’ the transverse; the slider bar and intersecting 
sections are also color-coded. The image display will interactively update, 
allowing the user to navigate through the interior of the data set.

10.	 The scale of each plane can also be changed using the Scale X, Y, and Z 
slider bars. To increase the scale of all planes in proportion to each other, 
uncheck the Individual Axis option; one Scale slider bar will replace the 
three slider bars, use this to increase and decrease the image size.

11.	 Right-click on the image display and choose Auto Save. Now, repeat some 
of the maneuvers described above; when you are finished, right-click again 
and uncheck the Auto Save option. The maneuvers performed have been 
recorded and saved to the Analyze workspace. The file can be reviewed 
with the Movie module (Display > Movie).

Figure 2

Exercise 8
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Multiplanar Sections

Figure 3

Cube Sections Tool

12.	 Open the Cube Sections Tool (Tools > Cube Sections). The Cube Sections 
tool provides an interactive display of orthogonal sections in a three-
dimensional viewing cube.

13.	 The View Angle and Scale options for the Cube Sections tool may be 
changed as described for the Intersecting Sections tool.

14.	 Planes can be interactively sliced away in the three orthogonal orientations 
to reveal interior sections of the cube with the Subregion X, Y, and Z 
double-ended slider bars. As with the Intersecting Sections tool, ‘X’ 
controls the sagittal orientation slices displayed, ‘Y’ the coronal, and ‘Z’ the 
transverse; the slider bars and cube sides are also color-coded.

15.	 After subregioning the data set, right-click on the image display and choose 
Extract Sub-volume. The subregioned data set will be saved to the Analyze 
workspace.

16.	 Click Done to close the Cube Sections tool.

17.	 Close the Multiplanar Sections module before proceeding to the Additional 
Task.

Exercise 8
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Multiplanar Sections: Adding Color Overlay

Figure 2

Figure 3

Windowed Object Local Max/Min Object Only Color Edges Edges Only

Figure 1

Creating a Grayscale Data Set with Color Overlaid Objects

1.	 Select the MRI_3D_Head data set in the Analyze workspace and 
then open the Multiplanar Sections module (Display > Multiplanar 
Sections).

2.	 Choose File > Load Object Map and load the MRI_3D_Head.obj 
object  map from the $:\BIR\images\TutorialData directory.

3.	 When the object map loads the Objects window will automatically open 
(figure 1). In the Objects window do the following:

•	 Set ‘Control by’ to ‘Attribute’

•	 Set the Display of all objects to ‘On’ with the exception of the 
Original and Skin objects.

4.	 Open the Scan Tool (Tools > Scan) and use the slice slider to review 
the display of the image data (figure 2).

5.	 Open the Intensity option (View > Intensities). In the Intensities window, 
review each of the Object Color modes by selecting each from the ‘Mode’ 
drop down menu.

Exercise 8.1

The ability to create a grayscale image overlaid with colored objects, also known as an Intensified Volume, can be useful. This exercise will 
demonstrate how to achieve this using the Multiplanar Sections module.
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Oblique Sections: Oblique Resizing of Volumes Exercise 9

Sometimes a particular structure of interest within a data set is not aligned with the orthogonal axes of the 3-D volume. The Oblique Sections 
module interactively generates any arbitrary plane through a data set and allows reformatting of a series or the entire data set. This exercise 
will demonstrate how to create an obliquely resampled data set for further analysis with Analyze.

1.	 Load the Canine_Chest_CT.avw data set from the $:\BIR\images\
TutorialData directory.

2.	 Open the Oblique Sections module (Display > Oblique Sections).

3.	 Open the Fly tool (Generate > Fly).

4.	 Use the Fly tool (figure 1) to rotate the current oblique plane from the 
transverse orientation to the sagittal orientation:

v.	 Click the Roll Right button nine times to rotate the oblique plane into the 
sagittal orientation. The Fly Value defaults to 10, so for each selection of 
‘Roll Right’, the plane is rotated by 10 degrees (90 total).

vi.	 Given that the view of this sagittal orientation is as if the body was in a 
prone position, click the Yaw Counter Clockwise button nine times to 
rotate the body upright. This is a right lateral view of the chest.

vii.	If a left lateral view is desired, click the Roll Left button to complete a roll 
of the oblique plane by 180 degrees (select the button 18 times). Note 
that the plane appears to rotate through the data set, passing from a right 
lateral view to a left lateral view.

8.	 Reset the oblique plane to the central transverse slice by selecting the ‘T’ 
Cube at the bottom of the Fly tool.

Figure 1tip The ‘Fly Value’ [B] can be changed to make incrementally larger or smaller 
changes when performing manipulations (e.g. set the ‘Fly Value’ to 180 and 
press ‘Roll Left’ once to rotate 180 degrees).
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9.	 Open the Matrix Tool (Tools > Matrix) to display the current transformation 
matrix that reflects this 3-D orientation (figure 2).

10.	 Now, complete the “fly” maneuvers as given above to rotate from the 
transverse orientation to the sagittal orientation again. Note the changes in 
the transformation matrix in the Matrix tool as these maneuvers are carried 
out. This demonstrates that the oblique plane manipulation is represented as 
a full 3-D transformation, with resampling of the data occurring based on the 
respective 3-D transformation as given in the matrix.

11.	 Use the Fly tool to select an arbitrary oblique orientation of your choice. For 
example, click the Roll Right button three times, then the Yaw Clockwise 
button four times.

12.	 To save the data set in this oblique orientation, choose File > Output.

13.	 In the Output window, set Destination to Workspace and change Name to 
xxx_myoblique (where ‘xxx’ are your initials) (figure 3).

14.	 To resample the entire data set, set Method to Reformat Entire Volume. Since 
this is an oblique orientation, the resampling space for the new data set may 
need to be larger than the original, so by default the Change to best fit data 
option is selected to output a large enough data set to capture all transformed 
voxels.

15.	 Click Generate Slices. The resampled data set is now saved to the Analyze 
workspace.

16.	 Close the Oblique Sections module before proceeding to the Additional Task.

17.	 To view your new reformatted data set, open it with the Multiplanar Sections 
module. 

Figure 2

Figure 3

Oblique Sections: Oblique Resizing of Volumes Exercise 9
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The Grid Align tools provide users with the ability to interactively reorientate image data using a grid overlay on the current oblique slice, this 
allows for easy reorientation with reference to structures in the slice. The grid allows for reorientation via translation and yaw of the oblique 
slice. This task will demonstrate how to reorientate data using the tool.

Exercise 9.1

1.	 Load the MRI_3D_Head.avw data set from the $:\BIR\images\TutorialData directory.

2.	 Open the Oblique Sections module (Display > Oblique Sections).

3.	 Open the Fly tool (Generate > Fly). Use the Fly tool to set the display orientation to Sagittal by clicking on the S-cube.

4.	 Next select Generate > Grid Align to apply the grid overlay to the current slice.

Translation:

•	 Click to select a point near the center of the grid axis (anywhere within the 36 center boxes). 

•	 While holding the mouse button down, move your cursor so that the center intersection of the grid is moved to the new 
desired location, in this example the middle of the cerebellum.

•	 Release the mouse button. The image will be translated with the selected region as the new center point. 

Oblique Sections: Grid Align
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5.	 Click on the S-Cube in the Fly tool to reset the image display.

Yaw

6.	 Click to select anywhere towards the outside of the grid (anywhere not within the 36 center boxes).

7.	 While holding the mouse button down, move your cursor to rotate the grid about the center axis, in this example, aligning a grid line 
along the brain stem.

8.	 Release the mouse button to apply the Yaw reorientation to the image.

9.	 Close all Oblique Sections windows before proceeding to the next exercise.

Oblique Sections: Grid Align Exercise 9.1
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Oblique Sections: Manual AC-PC Realignment Exercise 10

This exercise will review additional manual realignment tools available in the Oblique Sections module. The exercise will explain how to 
use these tools by demonstrating how to realign the brain along the AC-PC. Please note that the Mayo 3D Brain Atlas add-on provides an 
interactive AC-PC based alignment tool for realignment of volume image data to the Talairach-Tournoux coordinate and proportional grid 
system, for more information please review the Mayo 3D Brain Atlas exercise.

1.	 Load the MRI_3D_Head.avw data set from the $:\BIR\images\
TutorialData directory. Then open the Oblique Sections 
module (Display > Oblique Sections).

2.	 Once the Oblique Sections module is open, select the 
Orthogonals (Tools > Orthogonals).

3.	 In the Orthogonals window (figure 1), move to the mid-sagittal 
slice where the AC and PC can be identified using the slider bar 
under the sagittal display pane. It may be helpful to increase 
the display size of the sagittal slice. To do this, right-click on the 
pane and select the Size option.

4.	 At the bottom of the Orthogonal window, select the Interactive 
Perp Axis option to turn on the interactive generation of the 
perpendicular axis and the perpendicular oblique.

5.	 Now, on the sagittal image, move your cursor to either the AC or 
PC points and select this point with your mouse button. Hold the 
mouse button down as you drag the line from this point to the 
other AC or PC point. Release the mouse button when the other 
point has been selected.

6.	 This provides the AC-PC axis and generates an oblique image, which is 
perpendicular to the midpoint of this axis - essentially a coronal image.

7.	 The Perpendicular Axis window automatically opens (figure 2). This will allow 
you to note the coordinates of the AC and PC points (Point 1 and Point 2) if 
desired.

8.	 Open the Fly tool from the Generate menu in the main Oblique Sections 
window (Generate > Fly).

Figure 1

Figure 2
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Oblique Sections: Manual AC-PC Realignment
9.	 Change the Fly Value to 90 (figure 3), and do a Pitch maneuver. This 90 

degree pitch places the current oblique image in the plane of the AC-PC 
line.

10.	 Now change the Fly Value to a smaller value (e.g. 1 to 5 degrees).

11.	 Viewing the main oblique image, you can use the Roll and Yaw maneuvers 
to attempt to accommodate brain symmetry in this oblique plane. This is an 
entirely visual process and shouldn’t require much manipulation. Note that 
you may have to do other smaller manipulations along the way to adjust for 
the volume being tilted slightly, but you can do this at any time.

12.	 When satisfied with this ‘transverse-oblique’ along the AC-PC plane, select 
File > Output.

13.	 Change the Method to Reformat Entire Volume to generate the output 
volume at this new orientation. The option is available to reformat back into 
the original volume size (Maintained), or new output volume that can hold 
the entire span of the rotated original volume (Change to best fit data).

14.	 Select Generate Slices to save the AC-PC aligned volume to the Analyze 
workspace.

15.	 Close the Oblique Sections module before proceeding to the next exercise. 

Figure 3

note The anterior part of the brain should be at the top of the oblique image. If it is not, then you 
can do two more 90 degree pitch maneuvers to flip this oblique plane around 180 degrees.

Figure 4

Exercise 10
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Volume Compare Exercise 11

The Volume Compare module provides the ability to compare data sets images that have the same spatial resolution. This exercise will 
provide an overview of the module.

1.	 Load the MRI_3D_Head.avw and MRI_3D_Brain.avw data sets from the $:\ 
BIR\images\TutorialData directory. Select both data sets, MRI_3D_Head. 
avw first and MRI_3D_Brain.avw second.

2.	 Open the Volume Compare module (Display > Volume Compare).

3.	 Open the Blend window, select Yellow-Cyan. Click on any of the images and 
drag your cursor to move through the image display. Alternatively, use the 
arrow keys and the page up, page down keys to move through the data.

4.	 From the File menu, select Load First Object Map and load the MRI_3D_
Head.obj.

5.	 Next, load the MRI_3D_Brain.obj object map for the second volume (File > 
Load Second Object Map).

6.	 Use the crosshairs to navigate through the data (figure 2).

7.	 Double click in any pane to log points. To save the Point Log, 
click Save (figure 3).

8.	 To save the Fused Volume, select File > Save Fused.

9.	 9. Close the Volume Compare module before proceeding to the 
next exercise.

Figure 1

Figure 2Figure 3
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Volume Render: Basic Rendering Controls Exercise 12

The Volume Render module provides a variety of display representations for three-dimensional image data sets. Also provided in the module 
are tools for volume image editing and measurement. This exercise will demonstrate the different control parameters involved in the process 
of volume rendering. This includes demonstrating various rendering algorithms that are part of the suite of techniques used to render volume 
images with Analyze.

1.	 Load the Cubic_CT_Head.avw data set from the $:\BIR\images\TutorialData 
directory.

2.	 Open the Volume Render module (Display > Volume Render).

3.	 Press the Render PowerBar button or choose Generate > Render.

4.	 Open the Preview window (Generate > Preview).

5.	 To rotate the image data in this window, click and drag the mouse.

Thresholding Data

6.	 Open the Thresholds window (Generate > Thresholds).

7.	 Set the Threshold Minimum to 85 (figure 1) - all voxels with a value less than 85 
are now removed from view.

8.	 The resulting image can be seen in the Preview window (figure 2). Click Render to 
display the rendering in the main Volume Render window.

9.	 Now, set the Threshold Minimum to 145—all voxels with a value less than 145 
are now removed from view. Click Render.

Figure 1

Figure 2
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Volume Render: Basic Rendering Controls

Depth Shading Gradient Shading Volume Compositing Maximum Intensity 
Projection

Summed Voxel
Projection

Surface Projection

Rendering Algorithms

10.	 Open the Render Types window (Generate > Render Type) (figure 3).

11.	 Experiment with the rendering algorithms.

12.	 Select the Depth Shading option. View the rendering in the Preview window. Click 
Render to display the rendering in the main Volume Render window.

13.	 Select the Volume Compositing option. View the rendering in the Preview window. 
Click Render to display the rendering in the main Volume Render window (figure 7). 
For more information on the Volume Compositing Tissue Map Type Specific option, 
please review exercise 13, Volume Render – Tissue Map Tool.

14.	 Select the Maximum Intensity Projection option. Click Render to display the 
rendering in the main Volume Render window.

15.	 Select the Summed Voxel Projection option and click Render.

16.	 Select the Surface Projection option. Set the Threshold Minimum back to 145 in 
the Thresholds window, then click Render. This render type is more effective with 
different input data, but the effect can be seen using the current surface.

17.	 Select Gradient Shading before moving to the next section.

note

note

When working with anisotropic data, the ‘Interpolated Rays’ option may help to improve 
the quality of the rendering.

Additional parameters for each render type
are available in the Render Types window.
Upon clicking on each Render Type, notice
that type specific parameters will either
become enabled or disabled depending on
whether the parameter is supported.

Figure 3

Exercise 12
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Volume Render: Basic Rendering Controls

Figurre 5

Figure 6

Clip Tool

18.	 Open the Clip tool from the Render Type window or from (Generate > 
Clip).

19.	 The Clip tool (figure 5) allows a subregion of the volume to be rendered. 
Experiment with the Clip Plane and Clip Volume parameters.

20.	 Click Done to close the Clip tool.

21.	 Close all windows related to the Volume Render module before moving 
onto the next exercise.

Exercise 12
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Volume Render: Advanced Rendering Controls Exercise 13

Adding the ability to control specific objects in the rendering process provides incredible power and versatility in the creation of unique 
visualizations. In Analyze, this is possible with the use of object maps. Object maps are special image files that are used in Analyze to 
partition and identify structures as belonging to a particular segmented object. Voxels in the volume image correspond directly, on a one-
to-one basis, with a voxel in the object map, whose value assigns the voxel to a particular segmented object. Each of the objects within the 
object map can be controlled and manipulated independently. This exercise will begin to explore the power of object control in creating 3-D 
visualizations, but will only “scratch the surface” of the endless possibilities for exploration of this 3-D visualization space.

1.	 Load the Cubic_CT_Head.avw data set from the $:\BIR\images\TutorialData directory.

2.	 2. Open the Volume Render module (Display > Volume Render).

Defining Objects in an Object Map

3.	 Choose File > Create Object Map. The Objects window will automatically be returned; 
dismiss the window for now by clicking Done.

4.	 Open the Threshold Tool (Tools > Manipulate > Threshold) (figure 1).
•	 Set the Minimum Threshold to 85. 

•	 Set Change to Object Map.

•	 Set Defined Object to ***New***.

•	 Click Threshold Volume to define a new object. Note all voxels from 85 to 255 will be 
defined as a new object, ‘Object_2’.

•	 Click Done to close the Threshold Tool.

5.	 Open the Preview window (Generate > Preview) to interactively review your changes.

6.	 Click Render to display the rendering in the main Volume Render window (figure 2).

7.	 In the main Volume Render window, open the Thresholds window (Generate > Thresholds). 
Set the Threshold Minimum to 145 and click Render.

Figure 1

Figure 2
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Volume Render: Advanced Rendering Controls

Figure 5

8.	 Open the Connect Tool (Tools > Manipulate > Connect).

•	 Change the Connect Method to Connected Components.

•	 Set to Keep the ‘3’ Largest Objects.

•	 Click Label Components. The three largest objects will automatically be 
identified and labeled as new objects (figure 3).

•	 Click Done to close the Connect Tool.

Manipulating Objects

9.	 In the Objects window (View > Objects) (figure 4), click Reassign Object(s).

10.	 In the window returned (figure 5), select: BlueObject from the Reassign from 
list. From the drop down menu to the right select: YellowObject. Click Apply 
and then OK to dismiss the window. Note the update in the Preview window.

11.	 Click Remove Unused in the Objects window to remove ‘BlueObject’. Click 
OK in the dialog box returned.

12.	 Select the GreenObject from the Object drop-down menu. Then change the 
following attributes:

•	 Name: Bone
•	 Color: white
•	 Shades: 32

13.	 Select the YellowObject from the Object drop-down menu. Then change the 
following attributes:

•	 Name: Rope
•	 Color: red
•	 Shades: 8

14.	 Click Render.

15.	 In the Thresholds window (Generate > Thresholds), set the Threshold 
Minimum to 5.

16.	 Return to the Objects window and set Control by to Attribute.

note Up to 255 different 
objects can be defined 
in an object map.

Figure 3

Figure 4

Exercise 13
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Volume Render: Advanced Rendering Controls

Figurre 6

Figure 7

17.	 Set the Display attribute to Off for the Original object. Then, click 
Render.

18.	 Open the Render Types window (Generate > Render Type). Select the 
Object Compositing option, then open the Object Mapping window, 
(Generate > Type Specific > Object Mapping).

19.	 Select the Transparency render type (figure 6) and click Render to view 
the effects.

20.	 A variety of object attributes can be controlled in the Objects window. 
Set Attribute to Opacity by selecting it from the drop-down menu. 
Change the Bone object to 1 (opaque). Click Render (figure 7).

Saving an Object Map

21.	 Object maps can be saved for review or use at a later time, or to load 
into another Analyze module; choose File > Save Object Map to save 
the object map.

22.	 Name the file Cubic_CT_Head_xxx.obj (where ‘xxx’ are your initials) 
and specify a location to save the file, then click Save (object maps are 
saved as .obj files).

23.	 Close the Volume Render module before proceeding to the next 
exercise.

Exercise 13
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Volume Render: Tissue Map Tool Exercise 14

The Tissue Map tool provides a control interface that allows for the creation of unique visualizations. This exercise will demonstrate how to 
use the tool to generate visualizations of different tissues.

1.	 Load the CT_Heart.avw data set from the $:\BIR\images\TutorialData 
directory.

2.	 Open the Volume Render module (Display > Volume Render).

3.	 Open the Render Types window (Generate > Render Type).

4.	 Select the Volume Compositing render type (figure 1). Then open the Tissue 
Map tool by clicking the Tissue Map button.

5.	 A tissue map is a mapping of the voxel values within a volume to a given 
color and opacity. The Tissue Map tool provides several control options to 
aide in the creation of a tissue map for a volume.

6.	 The Tissue Map tool provides four control “points” to manipulate which voxel 
values are mapped to specific colors and opacity (figure 2).
•	 Start: The starting voxel value within the volume mapped to a specific 

color (chosen from the color drop-down menu) with 
0% opacity.

•	 Min: The minimum voxel value within the volume that 
will be mapped to a specific color and set opacity (e.g. 
44%).

•	 Max: The maximum voxel value within the volume that 
will be mapped to a specific color and set opacity (e.g. 
44%).

•	 End: The ending voxel value within the volume 
mapped to a specific color with 0% opacity. 

7.	 Click Render to view the rendering with the default 
parameters (displayed in the main Volume Render 
window).

Figure 1

Figure 2
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Volume Render: Tissue Map Tool

Figure 4 Figure 5

8.	 Use the slider bars, or type the numbers in the 
appropriate text box in the Tissue Map tool to set the 
following (figure 3):

•	 Start: 157

•	 Min: 200

•	 Max: 500

•	 End: 3072

9.	 Select 60 from the Opacity drop-down menu. Click 
Render to view the effect of the changes (figure 4).

10.	 Now, experiment by moving the control points in the 
graphical display. Click Render as desired.

11.	 Right-click in the graphical display and select Show 
Histogram; the volume histogram will be calculated and 
displayed. This option may help determine voxel values 
associated with tissues.

12.	 Several default tissue maps are also available, rightclick 
in the graphical display and choose Default Tissue 
Maps > CT2; once loaded, click Render (figure 5).

13.	 Experiment with adding a second tissue to the tissue 
map by clicking the + button to the right of the graphical 
display. Click Render as desired to see the effect.

14.	 Close the Volume Render module before proceeding to 
the next exercise.

Figure 3

Exercise 14
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Volume Render: Movie Making Exercise 15

The Volume Render module contains a number of tools for movie generation. This exercise will introduce the Sequence tool. While 
complicated movies can be created, the goal of this exercise is to demonstrate how to generate a quick, simple movie. For more information, 
please review the Movie Making with Volume Render Tutorial after you have completed this exercise. The tutorial can be accessed from the 
Help menu in the main Analyze workspace.

1.	 Load the Cubic_CT_Head.avw data set from the $:\BIR\images\TutorialData directory.

2.	 Open the Volume Render module (Display > Volume Render).

3.	 Choose File > Save Renderings (figure 1).

4.	 In the Save Renderings window, check the Save After Each Render option and change 
Name to MyTestMovie. The movie that is generated will automatically be saved to the 
Analyze workspace as ‘MyTestMovie’.

5.	 Click Done to dismiss the Save Renderings window.

6.	 Open the Sequence tool (Generate > Sequence).

7.	 By default, the ‘sequence’ already has one action, ‘Z Rotation’. To modify the 
action click Modify, and then click on the red ‘Z Rotation’ action (figure 2). The 
Action window will automatically be returned.

8.	 For the first part of this movie, we will threshold the data set to show the 
structure of interest, in this case the head. If you have completed Volume Render 
exercises 11 and 12, you will know that in order to view the head in this data set, 
we need to increase the threshold minimum to 85.

9.	 In the Action window, set the following parameters (figure 3):

•	 Action Name: Threshold

•	 Number of Frames: 36, the default frame display is 12 frames per second.

•	 Persistent: Checking the ‘Persistent’ option will ensure that the minimum threshold parameter 
set in this action will be retained for the rest of the movie. If not checked, the threshold 
minimum will be reset after the action is completed.

•	 Parameter: Threshold

•	 End Minimum: 85

Figure 1

Figure 2

Figure 3
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Volume Render: Movie Making
10.	 To preview the movie with the new action, first open the Preview window 

(Generate > Preview).

11.	 Now, in the Sequence tool, click Sequence. Then, click Make Sequence 
(figure 4).

12.	 A dialog box will be returned asking if you would like to ‘Preview’ or ‘Make the 
Sequence’, click Preview the Sequence. The movie will now be played in the 
Preview window.

13.	 Add another action to the movie. Click Add Action and place the new 
action on Track 2 in Frame 36; this will be directly under the last frame of the 
‘Threshold’ action (figure 5).

14.	 Once the new action has been added, click Modify and then click on the new 
action to open the Action window.

15.	 We will now add a rotation to the movie. Set the following parameters for the 
new action:

•	 Action Name: Rotation

•	 Number of Frames: 60

•	 Parameter: Rotation

•	 End Z: 720 (2 rotations, 360=1 rotation)

16.	 Click Done to dismiss the window.

17.	 Review the movie. Click Sequence, and then, with the Preview window open, 
click Make Sequence.

18.	 In the dialog box returned, click Preview the Sequence. The movie playing in 
the Preview window should show the data set being thresholded to the head, 
followed by two quick rotations about the Z-axis. 

note The ‘Preview the Sequence’ option is only available when the Preview window is open. If 
the Preview window is not open, the dialog box will not be returned after clicking ‘Make 
Sequence’, instead the sequence will automatically be generated.

Figure 4

Figure 5

note To slow the rotation of the data set, simply 
add more frames in the Action window (e.g. 
Change Number of Frames from 60 to 120), 
or only show one rotation by changing the 
End Z value to 360 from 720.

Exercise 15
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Figurre 7

19.	 To generate the movie, click Sequence again. This time, after clicking Make 
Sequence, choose Make the Sequence from the dialog box returned.

20.	 As the sequence is generated, each frame will be displayed in the main 
Volume Render window. Each frame is also being written to a movie file 
called ‘MyTestMovie’ in the Analyze workspace (specified earlier in the Save 
Renderings window).

21.	 Once sequence generation is complete, close the Volume Render module.

22.	 In the Analyze workspace, select the MyTestMovie file and review it using the 
Movie module (Display > Movie). (figure 6)

23.	 To save the movie out of Analyze, choose File > Save in the Analyze window. 
Choose a movie file format (AVI, QuickTime, or AnimatedGIF) from the Format 
dropdown menu before clicking Save.

24.	 Close the Movie module before proceeding to the next exercise.

Volume Render: Movie Making Exercise 15
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Volume Render: High Def Volume Rendering Exercise 16

The Volume Render module allows for the generation of High Definition Volume Renderings. This exercise will demonstrate how to generate 
a high definition volume rendering using a CT data set with a Volume Composite with a tissue map overlay. Note the high definition volume 
renders can be generated with any of the rendering algorithms available in the Volume Render module.

1.	 Load the CT_Heart.avw data set from the $:\BIR\images\TutorialData 
directory.

2.	 Open the Volume Render module (Display > Volume Render).

3.	 Open the Render Size option from the Generate menu and change the 
Width and Height of the Render size to 2000x2000. Then click Apply 
(figure 1).

4.	 Open the Render Type window from the Generate menu and select 
Volumetric Compositing, check the Interpolated Rays option (figure 2).

5.	 Click the Tissue Map button to open the Tissue Map tool. Right-click on the 
main tissue map panel and select Default Tissue Maps, choose the CT 2 default  
tissue map.

6.	 Now open the Perspective Rendering tool (Tools > Display > Perspective) and  
then click the Perspective Render button (figure 3). In Perspective mode, a ray 
is cast for every output pixel in the rendering. In this case 4 million (2000x2000) 
rays are cast through the current field of view 
(FOV) for the perspective geometry.

7.	 Note the Render Size controls the number of rays,  
and the FOV controls the space in the volume 
through which that number of rays is cast. It may 
take a little while to render depending on the 
volume size.

8.	 Once the rendering is complete, the HDVR will be 
displayed in the main Volume Render window.

9.	 To save the rendering, Select File > Save 
Rendering. Name the rendering HDVR and then 
click the Save Last Rendering button. 

10.	 Close the Volume Render module before 
proceeding to the next exercise.

Figure 1

Figure 2

Figure 3
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Volume Render: Parametric Mapping Exercise 17

Volume Render provides the ability to generate parametric maps when a related volume is loaded and the render type is set to gradient 
shading. This exercise will demonstrate how to use the parametric mapping option.

1.	 Load the SISCOM_Extracted_Brain.avw and 
SISCOM_4D_ActivityMap.avw data set from the $:\BIR\
images\TutorialData\AdditionalData directory.

2.	 Open the Volume Render module (Display > Volume 
Render). In the Volume Render window, select File > 
Input/Output Ports (figure 1).

3.	 Drag-and-drop the SISCOM_Extracted_Brain file from 
the Analyze workspace into the Volume port. Next, drag-
and-drop the SISCOM_4D_ActivityMap from the Analyze 
workspace into the Related Volume port.

4.	 Open the Preview window (Generate > Preview).

5.	 Open the Parametric Mapping window (Generate > Type 
Specific > Parametric Mapping).

6.	 In the Parametric Mapping window, set Parametric 
Mapping to On (figure 2).

7.	 Review the rendering in the Preview window. To rotate the 
image, drag and drop the rendering in Preview window 
(figure 3).

8.	 Review the effects of changing the Mapping Factor 
and Map Transparency Value options in the Parametric 
Mapping interactively in the Preview window.

9.	 To view the 4D multivolume over time, use the Which 
Mapping Volume option. Check Increment after each 
Render, then press Render, until you’ve made your way 
through the volumes (figure 4).

10.	 Close the Volume Render module before proceeding to the 
next exercise.

Figure 1

Figure 2 Figure 3

Figure 4
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Volume Render: Creating and Modifying Objects Exercise 18

Volume Render is a powerful display module. In the Volume Render module, you can use many different tools to create many different 
outcomes. This exercise will demonstrate an amalgamation of Volume Render tools, to create a desired display.

Creating the Object Map

1.	 Load the Coronary_CT.avw data set from the $:\BIR\images\TutorialData directory.

2.	 Select the data set and open the Volume Render module (Display > Volume Render).

3.	 Open the Toggle Preview window (Generate > Preview).

4.	 Open the Threshold tool (Tools > Manipulate > Threshold). Use the slider bar to 
increase the minimum threshold, note that the preview in the Preview window updates 
interactively. Increase the threshold until you have thresholded the heart - 63 is a good 
minimum value for this data set.

5.	 In the Threshold tool, set Change to Object Map. Set Define Object to ***New***.

6.	 Now select the Threshold Volume button. Your object map now contains one object; the 
heart.

7.	 In the Threshold tool, increase the Threshold Minimum until you see only the vascular 
system surrounding the heart, a minimum value of 133 is good. Set Define Object to 
***New***.

8.	 Select the Threshold Volume button again, Object_3 is created and contains only the 
vascular system (figure 2).

9.	 Set the Threshold Mimimum to 1 and then close the Threshold tool.

Figure 1

Figure 2
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Volume Render: Creating and Modifying Objects

Figure 4

Figure 5

Modifying the Object Display Options

10.	 Open the Objects window (View > Objects), at the top of the window set 
Control By to Attribute. Set the display of the Original to Off, then select 
Render.

11.	 In the main Volume Render module, select Generate > Render Type. In the 
Render Type window returned, select Object Compositing and then hit 
Render (figure 3). The render will show both the heart and the vessels.

12.	 In the Objects window, select Name from the Attribute drop down menu and 
change the name of Object_2 to Heart, and the name of Object_3 to 
Vessels.

13.	 Now select Color from the Attribute drop down menu and change 
the color of the Heart to Pink and the color of the Vessels to Red. 
Note that you can just type the name and hit enter to change the 
color of the object.

14.	 Now select Opacity from the Attribute drop down menu and change 
the opacity of the Heart to .02. Change the thickness of the Vessels 
to 2 (figure 4). You will see the Preview window update (figure 4). To 
view the results in the main Volume Render module, hit Render.

15.	 Experiment with other settings and tools within the Volume Render 
module.

16.	 To save your object map, select File > Save Object Map.

17.	 Close the Volume Render module before proceeding to the next exercise.

Figure 3

Exercise 18
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Volume Render: Fabricate Tool Exercise 19

The Volume Render Fabricate Tool allows for the creation of objects from a text file with coordinates or by user defined coordinates. This 
exercise will demonstrate how to create objects from a predefined log file. The log file provides a list of the coordinates, the centroids of 61 
electrodes from an electrode grid. Using the fabricate tool we will create an electrode object around each coordinate.

1.	 Load the Trans_Pre_OP_MRI and open it in the Volume Render 
module (Display > Volume Render).

2.	 Open the Fabricate Tool (Tools > Manipulate > Fabricate). Click the 
Alt button once and then click the File button (figure 1).

3.	 Navigate to the log file Electrodes_FabTool.log in the C:/BIR/ 
Images/TutorialData directory.

4.	 Adjust the Radius to 10. This will define an electrodes object with a 
radius of 10 voxels. Set Change to Object Map, then from the Defined 
Object menu select ***New***.

5.	 Click Create.

6.	 From the main Volume Render window, open the Preview window 
(Generate > Preview). To rotate the image, click and drag the 
rendering in the Preview window.

7.	 Open the Render Type window (Generate > Render Type), select 
Object Compositing, the rendering is shown in figure 3. Figure 1

Figure 2 Figure 3
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Surface Render: Surface Maps Exercise 20

Surface Render provides a semi-automated interface for the conversion of object maps into surface maps using the Adapt/Deform algorithm.

1.	 Load the Cubic_CT_Head.avw data set from the $:\BIR\images\TutorialData directory.

2.	 Open the Surface Render module (Display > Surface Render).

3.	 Choose File > Load Object Map and load the Cubic_CT_Head object map from the $:\BIR\
images\TutorialData directory. 

4.	 In the Objects window (View > Objects) returned, set Control by to Attribute and set the 
Display attribute to Off for the Rope, Left Skin, and Skull objects (figure 1).

5.	 Choose File > Create Surface Map. 

6.	 In the Surfaces window (View > Surfaces) returned, click From Object(s). A dialog box 
will be returned asking if you would like to create the surface map from all currently active 
objects, click Yes. The objects that have their ‘Display’ attribute set to ‘On’ (in the Objects 
window) will be tiled and a surface map generated.

7.	 Once the surface map is generated, click Render to display the results (figure 2).

8.	 Choose File > Load Surface Map and load the Cubic_CT_Head.smp surface map from 
the $:\BIR\images\TutorialData directory.

9.	 Click Render to display the results.

10.	 Open the Camera tool (Generate > Camera) and set Sort to Front-Back (figure 3). Click 
Render to display the results.

11.	 In the Surfaces window set Control by to Attribute. Choose Shading from the Attribute drop-
down menu and change the shading of the Right Skin surface to Gouraud. 

12.	 Click Render, note the changes in the rendering (figure 4). Experiment with the different shading 
options.

13.	 Choose File > Save Surface Map to save changes made to the surface map.

14.	 If you wish to export the surface map out of Analyze for use in another application, choose File 
> Export Surface Map. Surface maps can be exported out of the Surface Render module in the 
Inventor (.iv) or VRML (.vrml) surface description formats.

15.	 Close the Surface Render module before proceeding to the next exercise.

Figure 1

Figure 2

Figure 3
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Virtual Endoscopy Exercise 21

Virtual Endoscopy is an important visualization application that results from the ability to create 3-D visualizations from a viewpoint inside of the 
body. This exercise will familiarize you with the Virtual Endoscopy module, demonstrating basic functionality and various methods of controlling the 
view.

1.	 Load the CT_Lungs.avw data set from the $:\BIR\images\TutorialData directory.

2.	 Open the Virtual Endoscopy module (Display > Virtual Endoscopy).

Basic Controls

3.	 Position the cursor on the image display near the 
center of the trachea (the hole in the flat surface)  
and click once; this will be set as the new ‘Look At’ 
point and the ‘Eye’ position will advance (figure 1).

4.	 Position the cursor on the flat surface outside of the trachea and click once.

5.	 The ‘Back’ PowerBar button can be used to reposition to previous locations; the 
‘Forward’ PowerBar button will move to the next location if one has been defined. 
Press the Back button once.

6.	 Position the cursor over the center of the trachea and click several times to navigate 
into the trachea. Then, press the Back button until you return to the starting location.

Advanced Controls

7.	 Open the View Parameters window (Generate > View Parameters).

8.	 Set the Move Percent to 50. Now, click again on the image display near the center 
of the trachea; note the effect of increasing the Move Percent (figure 2).

9.	 The View Parameters window (figure 3) also allows you to specify a location by 
typing in coordinates. Set the following coordinates:

•	 Eye 	 X: 128 		 Y: 150 		 Z: 181

•	 Look At 	 X: 125 		 Y: 142 		 Z: 120

•	 Up 		 X: 0 		  Y: 1 		  Z: 0

10.	 Click Render in the View Parameters window to display the location of the 
coordinates (figure 4). 

Figure 1

Figure 3

Figure 2

Figure 4

tip The ‘Eye’ position advances
toward the selected point
based on settings in the
View Parameters window.
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Virtual Endoscopy
11.	 Reset Move Percent to 20 in the View Parameters window and click 

Done to dismiss the window.

12.	 Many times when an obvious entry location is not available, the 
‘Orthogonal Eye’ and ‘Look At’ views are very useful. To enable these 
views, press the Eye and Look At PowerBar buttons or choose View 
> Eye and View > Look At. When enabled, three interactive panes 
become available (figure 5) on either side of the module window, 
displaying the transverse, coronal, and sagittal sections that intersect 
with the current ‘Eye’ position or ‘Look At’ point. A new ‘Eye’ position 
or ‘Look At’ point can be set by clicking in any of the orthogonal 
section panes.

13.	 Press the Manual Controls PowerBar button or choose Generate 
> Manual Controls. The Manual Controls will appear in the main 
module window, allowing you to select the translation or rotation 
actions, the increment, and point(s) to manipulate. To apply a manual 
action, click the Render button at the bottom of the main module 
window.

14.	 Use the interactive Orthogonal Eye/Look At panes and the Manual Control buttons to 
navigate down into the trachea until you reach the bifurcation of the airway.

15.	 Press the Show Object PowerBar button or choose Generate > Show Object. 
The Show Object window allows the ‘Eye’ position and ‘Look At’ direction to be 
manipulated on an exterior rendering. The rendering shows a circle indicating the ‘Eye’ 
position and an arrow for the ‘Look At’ direction (figure 6). 

 
 

16.	 Close all Virtual Endoscopy windows before proceeding to the next exercise.

Figure 5

Figure 6

tip

note

The ‘Eye’ position advances toward the selected point based on settings in 
the View Parameters window (Generate > View Parameters).

Since the visualization is created by thresholding, you must be  
“inside” the object in order for it to be rendered. 

Exercise 21
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Virtual Endoscopy: Movie Generation Exercise 22

The Virtual Endoscopy module provides an interactive interface for endoscopic visualization. Often the desired result of such an endoscopic 
exploration is a detailed endoscopic movie sequence along a specified ‘fly-through’ path. This exercise will demonstrate how to achieve this by 
defining a path using key frames then generating all endoscopic renderings along this path.

1.	 Load the CT_Lungs.avw data set from the $:\BIR\images\TutorialData directory.

2.	 Open the Virtual Endoscopy module (Display > Virtual Endoscopy).

3.	 Before beginning to record the movie, move closer to the trachea. Position the cursor near the 
center of the trachea and click three times to cause incremental movement towards the target.

4.	 Press the Add Key Frame PowerBar button or choose Generate > Sequence > Add Key 
Frame to specify the first key frame (this is where the movie will begin).

5.	 Move closer to the trachea by clicking three more times within the tracheal lumen (figure 1). 
After the movement towards the trachea has stopped, press the Add Key Frame button to add 
another key frame.

6.	 Choose Generate > Sequence > Auto Key Frame, this option causes any new viewpoint to 
automatically be added as a key frame.

7.	 Continue to click within the tracheal lumen and navigate down to the bifurcation of the airway 
(approximately 9 clicks) (figure 2).

8.	 When you reach the bifurcation of the airway, click in the left bronchus to reorient the viewpoint 
down that specific branch. Click several more times to traverse down the left bronchus.

9.	 When you have moved down the left bronchus (figure 3), choose Generate > Sequence > Auto 
Key Frame to turn off the Auto Add Key Frame option.

10.	 To save the sequence, choose Generate > Sequence > Save Sequence.

11.	 To generate a movie of the sequence, choose Generate > Sequence > Generate Sequence. 
The full sequence (defined by the key frames) will now be generated by the module; all 
endoscopic renderings will be generated along the defined path.

12.	 The fly-through movie will be available in the Analyze workspace and can be viewed with the 
Movie module (Display > Movie).

Figure 1

Figure 2

Figure 3

note Rendering the endoscopic movie may 
take a few minutes depending upon
your system and the size of the movie.
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Virtual Endoscopy: Centerline Generation

Figure 2

Figure 3

1.	 Load the CT_Lungs.avw data set from the $:\BIR\images\
TutorialData directory.

2.	 Open the Virtual Endoscopy module (Display > Virtual 
Endoscopy).

3.	 Position the cursor over the center of the trachea and click to 
navigate into the trachea. Clicking 12 times should position you 
midway into the trachea (figure 1).

4.	 Press the Eye and Look At PowerBar buttons to enable the Eye and 
Look At views. Then press the Show Object PowerBar button to 
open the Show Object window.

5.	 In the Show Object window, click on and drag the green arrow (the 
Look At point) to the end of the airway (figure 2).

6.	 Use the Look At panels to correct 
the Look At position, make sure that 
the Look At position is on the airway 
(figure 3).

Figure 1

The Virtual Endoscopy module provides the ability to generate the centerline of an endoscopic structure using the current Eye and Look At points. 
Key frames are automatically generated between the two points and displayed in the Sequence Edit window once the centerline has been created, 
allowing an endoscopic sequence to be generated along the centerline, thus reducing the time taken to create fly-through movies. This task will 
show you how to create a centerline and generate the resulting endoscopic movie. 

Exercise 22
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Virtual Endoscopy: Centerline Generation
7.	 Next select Generate > Generate Centerline. The module will 

calculate the centerline between the current Eye and Look At points. 
Once calculated, the Sequence Edit tool will open displaying the 
automatically generated key frames, the centerline will be displayed in 
the Show Object window (figure 4).

8.	 To generate the endoscopic movie, select Generate > Sequence > 
Generate Sequence. The endoscopic movie based on the centerline 
will be generated and saved to the Analyze workspace.

9.	 Close all windows associated with the Virtual Endoscopy module 
before proceeding to the next Additional Task.

note If you do not have the Look At point centered exactly in the airway, you will 
receive an error when generating the centerline. If this happens, reposition your 
Look At point and try again.

Figure 4

Exercise 22
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Image Calculator: Image Manipulation Exercise 23

This exercise will demonstrate how to use the Image Calculator module for rudimentary image processing and manipulation.

1.	 Load both the MRI_3D_Head.avw and MRI_3D_Brain_Bin.avw data sets from the $:\BIR\
images\TutorialData directory.

2.	 With the MRI_3D_Head data set selected in the Analyze workspace, open the Image Calculator 
module (Process > Image Calculator).

3.	 In the Image Calculator module, the MRI_3D_Head data set icon 
should appear in the white space above the calculator (figure 1).

4.	 Click the Multiply button on the calculator.

5.	 Drag-and-drop the MRI_3D_Brain_Bin data set from the Analyze 
workspace into the Image Calculator module (white space).

6.	 This first manipulation demonstrates how to multiply a grayscale data set with a binary data set. 
The binary brain will act as a mask; all voxels in the grayscale data set that fall within the binary 
mask will be kept, while the voxels that fall outside will be removed.

7.	 Click the Equals button on the calculator. A dialog box will be returned stating that the action 
modifies the loaded volume, click Change a Copy of the Loaded Volume.

8.	 The masked grayscale data will appear in the Image Calculator module; a copy will be 
automatically be saved to the Analyze workspace.

9.	 Click the Multiply button again.

10.	 Click the Matrix button on the calculator.

11.	 The Matrix Tool will open (figure 2); set to Rotate around the Z-axis 45 
degrees and click Apply. Click Done to close the Matrix Tool.

12.	 Click the Equals button on the calculator. A Transformation window will 
be returned; use the default settings and click Transform.

13.	 The transformed data will appear in the Image Calculator module and 
the copy in the Analyze workspace will be updated.

Figure 1

Figure 2

note In order to be able to drag-and-
drop data sets from the Analyze work-
space into the module, make sure that 
the Analyze window is not maximized 
to full window display.
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Figure 4

Figure 5

Figure 3

Image Calculator: Image Manipulation
14.	 Right-click on the calculator and choose Buttons; 

the Button Tool will open (figure 3).

15.	 The Button Tool includes a ‘Palette’ and ‘Key Pad’ 
(figure 3). To add a button to the main calculator, 
drag-and-drop it from the ‘Palette’ to the ‘Key Pad’ 
area of the Button Tool.

16.	 Click the Flip button that now appears on the 
calculator (figure 4).

17.	 In the Function Options window returned, check 
the Flip X option and click Apply (figure 5).

18.	 View the results by clicking the Volume button on 
the calculator.

19.	 A copy of the data set (as specified earlier) with the 
manipulations performed has automatically been 
saved to the Analyze workspace.

20.	 Close the Image Calculator module before 
proceeding to the next exercise.

Exercise 23
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Image Calculator: SubRegion Data Exercise 24

The Image Calculator module performs mathematical operations on volumes, matrices and constant numerical values. The module also contains 
a number of processing functions including: subregioning (crop), flipping, resizing, shifting etc. This exercise will demonstrate how to use some of 
these additional processing tools to manipulate your data.

1.	 Load the MRI_3D_Head.avw data set from the $:\BIR\images\TutorialData 
directory.

2.	 Open the Image Calculator module (Process > Image Calculator).

3.	 In the Image Calculator module, right click on the white space and select 
Buttons from the menu options (figure 1).

4.	 In the Button Tool, select the Region Pad button from the palette on 
the left, and drag and drop it onto the Key Pad on the right.

5.	 After the Region Pad button has been moved to the Key Pad, hit Apply. The 
main Image Calculator key pad will be updated with the additional button 
option. Close the Button Tool.

6.	 Now drag and drop your data set from the Analyze workspace onto the 
Image Calculator process canvas (the white space). This will load the data 
set into the module and the volume will appear on the canvas.

7.	 Hit the Region Pad button, the Region Pad button’s Subregion-Pad 
Volume window will be returned (figure 4).

8.	 In this window you can subregion the data by entering Low and High values 
for the X, Y and Z options.

X Low - Specifies the first column of pixels from each slice to be loaded.
X High - Specifies the column end point
Y Low - Specifies the first row of pixels from each image to be loaded
Y High - Specifies the row end point
Z Low - Specifies the first slice from the selected volume to be loaded
Z High - Specifies the slice endpoint

Figure 1

Figure 2

Figure 3 Figure 4
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Image Calculator: SubRegion Data

Example 1: Subregioning 50 slices in the X.

•	 Set the X Low value to 25

•	 Set the X High value to 162

Example 2: Subregioning 50 slices in the Y.

•	 Set the Y Low value to 25

•	 Set the Y High value to 211

Example 3: Subregioning 50 slices in the Z.

•	 Set the Z Low value to 25

•	 Set the Z High value to 151

9.	 Click on the Interactive button in the Subregion window.

Exercise 24
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Image Calculator: SubRegion Data
10.	 Now use the interactive tool to subregion. Use the tool to trace a 

bounding box around the area you wish to subregion.

•	 To define the box, simply click and drag the box on the image display.

•	 You can review and adjust the box in all three orthogonal orientations, by 
using the T, C, or S cube icons to change orientations.

•	 You can review your subregion on all slices prior to applying the 
subregion, use the slice slider bar to navigate through the volume.

11.	 A subregion defined in the Interactive tool automatically updates in 
the X,Y and Z high/low values in the Region Pad Function Option 
window. To apply a subregion to a data set, hit Apply in the Region Pad 
Function Option window.

12.	 When you Apply a subregion you will be asked if you would like to 
apply the changes to the Loaded or if you would like to Change a Copy 
of the Loaded Volume. Select Change a Copy of the Loaded Volume. 
The changes made to the copy of the data set will automatically be 
saved to the Analyze workspace.

13.	 Close all windows associated with Image Calculator before proceeding 
to the next exercise.

Exercise 24
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Image Algebra: Formula for Image Manipulation Exercise 25

The Image Algebra module provides an algebraic formula parser, allowing both simple and complex algebraic operations (containing up to 1000 
variables and 1000 constants) to be performed on image data. This exercise will demonstrate the use of common algebraic processing and other 
manipulations with the Image Algebra module.

1.	 Load the Cubic_CT_Head.avw data set from the $:\BIR\images\
TutorialData directory.

2.	 Deselect the Cubic_CT_Head data set in the Analyze workspace, and then 
open the Image Algebra module (Process > Image Algebra).

Thresholding Data

3.	 You may remember from previous exercises (Volume Render 12 and 13), that 
the Cubic_CT_Head data set can be thresholded to 145 to show bone.

4.	 Enter the formula: Output = (a > 145) * a. Press <Enter> (figure 1)

5.	 Drag-and-drop the Cubic_CT_Head data set from the Analyze workspace 
into the Image Algebra module under variable ‘a’.

6.	 Click the Output button; in the Parameters window returned, set Name to 
Bone. Click Done to dismiss the window.

7.	 Click Go in the main Image Algebra window to begin processing.

8.	 Once processing is complete, right-click on the Output icon and select 
Display to examine the data with all voxels less than 145 removed (figure 2). 
Close the Display tool once the data has been reviewed.

Manipulating Data

9.	 In the Image Algebra module edit the formula: Output = (a < 145) * a. Press 
<Enter>. All voxels greater than 145 will now be removed from the data set.

Figure 1

Figure 2

note The Image Algebra module remembers parame-
ters from previous Image Algebra sessions. If the 
module detects parameters from a past session, it 
will prompt the user to remember or forget these 
settings.
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10.	 Click the ‘a’ button to view the parameters for variable ‘a’ (figure 3). 
Click Done to dismiss the Parameters window.

11.	 Click the Output button and change Name to NoBone. Click Done 
to dismiss the window.

12.	 Click Go in the main Image Algebra window to begin processing.

13.	 Once processing is complete, right-click on the Output icon and 
select Display to examine the data with bone removed.

14.	 Now, try adding the bone back in with the new formula: Output = (b 
>= 1) * b + (b < 1) * a. Press <Enter> (figure 4).

15.	 Since we have reused the ‘a’ variable, the Image Algebra module 
will remember the data associated with it from the previous 
example. However, this is the first time the ‘b’ variable has been 
specified, so drag-and-drop NoBone (from Output or the Analyze 
workspace) to the area under variable ‘b’.

16.	 Click the Output button and change Name to BoneAdded. Click 
Done to dismiss the window.

17.	 Click Go to process the new formula (figure 4).

18.	 Once processing is complete, right-click on the Output icon and 
select Display to examine the data with the bone added back.

19.	 Right-click in the formula field and explore some of the example 
formulas provided.

20.	 Close the Image Algebra module before proceeding to the next 
exercise.

Image Algebra: Formula for Image Manipulation

Figure 3

Figure 4

Exercise 25
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Image Repair Exercise 26

The Image Repair module is a module that includes the ability to designate bad slices or subregions that can be ‘repaired’ by copying voxels from 
neighboring slices, interpolating across neighboring slices, copying from a related volume, or removed from the volume. Subregion repair includes 
the ability to blend voxels at the edge of the region.

1.	 Load the VH_Abdomen.avw data set from the $:\BIR\images\
TutorialData directory.

2.	 Open the Image Repair module (Process > Image Repair).

3.	 In the Image Repair module (figure 1), use the Displayed Slice slider 
bar to locate the first corrupt slice. Note that the first corrupt slice is 
slice 276.

4.	 In the Bad Slice(s) portion of the window, set slice 276 as the first 
bad slice.

5.	 Now, use the Displayed Slice slider bar to locate the last corrupt 
slice. Note: the last corrupt slice is slice 279.

6.	 In the Bad Slice(s) portion of the window, set slice 279 as the last 
bad slice.

7.	 Select Interpolate Between the First Good Slices for the 
correction method.

8.	 Click Repair Slice(s). A dialog box will be returned, click Change 
a Copy of the Loaded Volume. The fix will now be applied to a 
copy of the data set; the fixed data set will be saved to the Analyze 
workspace as ‘VH_Abdomen0’.

9.	 Close the Image Repair module before proceeding to the next task.

Figure 1



Analyze 12.0 Training Guide 70

Image Repair: Repair a Bad Region Exercise 26.1

The ‘Bad Region’ option provides the user the ability to define only a selected region to be repaired. To demonstrate this option we will use the 
VH_Abdomen data set and repair only the corrupt regions.

1.	 Select the VH_Abdomen data set in the Analyze workspace and 
open the Image Repair module (Process > Image Repair).

2.	 As in the main exercise, set slice 276 as the first bad slice and slice 
279 as the last bad slice.

3.	 Select the Bad Region option, the region boundaries and region 
sliders will appear.

4.	 Adjust the region sliders until just the corrupt area is defined (figure 
1).

5.	 Try adjusting the Blend Border and Correction Method. Review 
the different results.

6.	 Click Repair Slice(s). Slices 276 through 279 will be corrected 
according to the region and correction method. A dialog box will be 
returned, click Change a Copy of the Loaded Volume.

7.	 Close the Image Repair module before proceeding to the next 
exercise.

Figure 1
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Histogram Operations: Histogram Normalization Exercise 27

The Histogram Operations module provides the ability to do histogram processing, such as histogram matching, flattening, and equalization 
(normalization). The goal of this exercise is to demonstrate how to normalize the histograms of SPECT images taken under different conditions.

1.	 Load both the SISCOM_Ictal_SPECT.avw and SISCOM_Interictal_SPECT.
avw data sets from the $:\BIR\images\TutorialData directory.

2.	 With only the SISCOM_Ictal_SPECT data set selected in the Analyze 
workspace, open the Histogram Operations module (Process > Histogram 
Ops).

3.	 Open the Function window (Generate > Function).

4.	 In the Function window select Histogram Normalize and set the following 
parameters (figure 1):

•	 Use Histogram: Median

•	 Target Value: 150

•	 Image Display: Original and Filtered

•	 Histogram Display: On

5.	 Click Filter. An Input and Output Histogram will automatically be returned. The 
filtered result will be displayed in the main Histogram Operations window.

6.	 In the Function window change Action to Memory and click Filter again. A 
dialog box will be returned stating that the action modifies the loaded volume, 
click Change a Copy of the Loaded Volume.

7.	 Drag-and-drop the SISCOM_Interictal_SPECT data set from the Analyze 
workspace into the main Histogram Operations window.

8.	 Press the Filter PowerBar button. In the dialog box returned, click Change a 
Copy of the Loaded Volume.

9.	 The two new volumes you have created have been normalized to the same 
value, so equivalent numbers in the images now indicate levels of metabolic 
activity (figure 2). Additionally, both normalized volumes have automatically 
been saved to the Analyze workspace.

10.	 Close the Histogram Operations module before proceeding to the next exercise.

Figure 1

Figure 2
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Spatial Filters Exercise 28

The Spatial Filters module enables the application of two-dimensional and three-dimensional filters to image data. This exercise will demonstrate 
how to apply a filter in the Spatial Filters module to your data.

1.	 Load the MRI_3D_Head.avw data set from the $:\BIR\images\
TutorialData directory.

2.	 Open the Spatial Filters module (Process > Spatial Filters).

3.	 Open the Preview Options window (Generate > Preview Options).

4.	 Select the Loaded and Preview Volumes option (figure 1). This will 
preview the original data set and a copy of the data set with any filter 
applied, side-by-side.

5.	 Open the Filters window (Generate > Filters).

6.	 In the Filters window, select the Low Pass filter by clicking the radio button next 
to the option (figure 2).

7.	 Now, click Preview. The original data set and the filtered data set will be 
displayed side-by-side in the main Spatial Filters window (figure 3), the filtered 
data set appears on the right.

8.	 Preview several other filters, noting the effect of each.

9.	 To apply a filter to the data set, click Filter in the Filters window. A dialog 
box will be returned stating that the action modifies the loaded volume, click 
Change a Copy of the Loaded Volume.

10.	 A filtered copy of your volume will be saved to the Analyze workspace.

11.	 Close the Spatial Filters module before proceeding to the next exercise.

Figure 1

Figure 2

Figure 3
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Filter Designer Exercise 29

The Filter Designer module is a general-purpose 2D image processing tool which performs convolution and deconvolution in the frequency domain 
using the Fast Fourier Transform (FFT). This exercise will demonstrate how to use the Filter Designer process functions available when a data set 
and it’s associated Point Spread Function are loaded.

1.	 Load the Chromosome_2D_512 and Chromosome_2D_PSF data sets from 
C:\BIR\images\TutorialData\ImageProcessingTutorial.

2.	 Select Chromosome_2D_512 and open the Filter Designer module (figure 1) 
from the Process menu.

3.	 Drag and drop the PSF file from the workspace onto the PSF input icon.

4.	 Double-click on the Input icon to open the Input Selector window, and double 
click on the Output icon to open the Output Viewer.

5.	 The Convolver function has automatically been applied to the data. The Fourier 
transform of the selected section (slice) of the input volume is multiplied by the 
Fourier transform of the selected section (slice) of the PSF volume. The output 
is the inverse Fourier transform of the resulting spectrum.

6.	 Compare the input (figure 2) and output (figure 3) images.

7.	 Right-click on the Output icon and select ‘Store This Section’ option. The 
output data set will be saved to the Analyze workspace. If desired the Filter and 
Spectrum generated by the process can also be saved in this manner.

8.	 Change the function to Generate > Process > Cross Correlator.

9.	 A cross correlation function of the selected section of the input 
volume with the selected section of the PSF volume will be 
generated.

10.	 Compare the input and output images.

11.	 Review the other functions available from the Generate > Process 
menu. Adjust the associated parameters to see the effect on the 
filtered image data.

Figure 1

Figure 2: Convolver Input Figure 3: Convolver Output
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Filter Designer: Defining Filters Exercise 29.1

Filter Designer is a general-purpose 2D image processing tool, the module allows users to interactively define a representation of a frequency filter. 
This exercise will show you how to manually define filters to filter your image data.

1.	 Select MRI_3D_Head and open the Filter Designer module (Process 
> Filter Designer).

2.	 Set the Slice to 100 (Generate > Slice) (figure 1). 

3.	 In the Filter Designer window draw a Low Pass filter (figure 2).

4.	 After releasing the mouse the filter will be applied to the current slice.

5.	 Double click on the Output image to view the effect of the low pass 
filter (figure 3).

6.	 Now in the Filter Designer window, define a High Pass filter (figure 4).

7.	 Note the update to the Output image (figure 5).

8.	 To save the current filtered image right-click on the output image and 
select Store This Selection. Set Change a Copy of Image Data 
when prompted. Slice 100 in the data set will be filtered.

9.	 To review the filtered data, open it with the Multiplanar Sections 
module. The filter has been applied to slice 100.

Figure 4

Figure 5

Figure 3

Figure 2

Figure 1



Analyze 12.0 Training Guide 75

Segmentation
Analyze 12.0: Essential Training Guide
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Image Edit: Manual Segmentation Exercise 30

The Image Edit module provides a number of manual segmentation tools. This exercise will demonstrate how to segment grayscale data using the 
auto trace tool. For a full overview of all the segmentation tools in the module, please review the Image Edit tutorial available from the Help menu in 
the Analyze window.

1.	 Load the MRI_3D_Head.avw data set from the $:\BIR\images\TutorialData directory.

2.	 Open the Image Edit module (Segment > Image Edit).

3.	 Use the Slice Slider to move to Slice 122.

4.	 In the main Image Edit window, select the Auto Trace tool. Position the cursor near 
the center of the brain and click to set a seed point. The Image Edit window will 
automatically update to display Auto Trace parameters (figure 1).

5.	 Use the double-ended slider bar at the bottom of the window to adjust the threshold 
range until a reasonable trace of the brain is obtained. A threshold minimum of 34 and 
maximum of 129 works well for this data set.

6.	 Select the Delayed Flood Fill tool and place a fill point outside the auto-traced region 
(click on the background).

7.	 Select the Auto Trace tool again and click Apply & Advance.

8.	 A dialog box will be returned stating that the action modifies the loaded volume, click 
Change a Copy of the Loaded Volume. The area outside the trace will be highlighted in 
red, and then the next slice will appear in 
the image display (the slice number can be seen in the  
lower left corner of the image display).

9.	 Review the edited slice by opening the Edit Review Tool (Tools > Edit Review) 
(figure 2).

Figure 1

Figure 2

note An edited version of the data set will be automatically saved to the 
Analyze workspace.
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Image Edit: Manual Segmentation

Figure 3

10.	 In the main Image Edit window, you will notice that when the module 
advanced to slice 123 (step 8) the seed point and auto trace parameters set in 
step 5 were copied forward. The trace should have automatically adjusted to 
the brain on this slice. If not, the seed point may have been copied forward to 
an area outside the brain or to a voxel with a different grayscale value. Use the 
Move button and adjust the seed point.

11.	 If the trace needs no further adjustment and the Delayed Flood Fill point is still 
positioned outside the trace, click Apply & Advance and edit 19 more slices, 
finishing on slice 142.

12.	 In the Edit Review tool, change the orientation to Coronal and then Sagittal, 
note the slice edits in these orientations (figure 3).

13.	 Close all windows related to Image Edit before moving to the next exercise.

Exercise 30
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Image Edit: Object Map Creation Exercise 31

1.	 Load the MRI_3D_Head.avw data set from the $:\BIR\images\TutorialData directory.

2.	 Open the Image Edit module (Segment > Image Edit).

3.	 Choose File > Create Object Map. The Objects window (View > Objects) will automatically 
be returned (figure 1).

4.	 Click Add Object to create a new empty object (Object_2).

5.	 Change Name from Object_2 to Brain. Click Done to dismiss the Objects 
window.

6.	 Use the slider bar to move to Slice 122.

7.	 At the bottom of the main Image Edit window, set Change to Object Map and 
choose Brain from the Defined Object drop-down menu.

8.	 Select the Auto Trace tool; the Image Edit window will automatically update to 
display Auto Trace parameters (figure 2).

9.	 Position the cursor near the center of the brain and click to set a seed point. Use 
the double-ended slider bar at the bottom of the window to adjust the threshold 
range until a reasonable trace of the brain is obtained. A threshold minimum of 
34 and maximum of 129 works well for this data set.

10.	 Select the Delayed Flood Fill tool and place a fill point inside the auto-traced 
region (click inside the region).

11.	 Select the Auto Trace tool again.

12.	 Click Apply & Advance. The next slice will appear in the image display (the slice 
number is displayed in the lower left corner).

As discussed in Exercise 13: Volume Render Advanced Controls, object maps are special image files that are used in Analyze to partition and 
identify structures as belonging to a particular segmented object. This exercise will demonstrate how to create an object map containing manually 
segmented objects.

Figure 1

Figure 2



Analyze 12.0 Training Guide 79

13.	 View the edited object map by opening the Edit Review Tool (Tools > Edit Review).

14.	 Select the Previous option in the Edit Review tool. The change can also be viewed by 
selecting the Coronal option (figure 3).

15.	 With the Auto Trace tool selected, continue to segment slices by clicking Apply & 
Advance in the main Image Edit window. Segment the brain on 20 slices (to slice 142). 

16.	 To save the created object map for use in other Analyze modules, choose File > Save 
Object Map. Save the object map as xxx_mybrain.obj (where ‘xxx’ are your initials).

17.	 Close all windows before moving to the next exercise.

note If the auto trace does not apply to a slice, or leaks to unwanted structures, try the following: 1) 
adjust the threshold range, 2) draw a limit after selecting the ‘Add Limit’ button, or 3) turn on the 
‘Auto Limit’ option and adjust the ‘Gap Size’. Additionally, the auto trace can be adjusted on a 
slice by moving the seed point with the ‘Move’ button selected.

Image Edit: Object Map Creation

Figure 3

note If you did not set the ‘Change’ option to Object Map (step 7) the defined region 
will appear black in the Edit Review tool.

Exercise 31
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Volume Edit Exercise 32

The Volume Edit module provides interactive segmentation tools for manual and semi-automated object definition of structures using an intuitive 
3D interface. This exercise will provide an overview of how these tools can be used to interactively build an object map.

1.	 Select MRI_3D_Head from the Analyze 
Workspace, and open the Volume Edit module 
(Segment > Volume Edit).

2.	 Click the Add Object button to add a new object. 
Change the Name to Skin and Color to Tan.

3.	 Select the Semi-Automatic tab, and then select 
Threshold.

4.	 Adjust the threshold using the double-ended 
slider. Set the Minimum Threshold to 44 and the 
Maximum Threshold to 255. Click the Define 
Object button.

5.	 The next step is to extract the brain. Select 
Object Extractor, and click the Add Object 
button, change the Name to Brain and Color to 
Pink. In the Transverse orientation, move to slice 
135.

6.	 Click to set a seed point within the white matter 
(figure 2).

7.	 Adjust the Minimum Threshold to 48 and the 
Maximum Threshold to 141. Click Extract 
Object.

tip To toggle through intensity display options, press
Ctrl+F9 on your keyboard. Review the options and
decide which is most useful to you.

Figure 3

Figure 2

Figure 1
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8.	 The brain will be extracted as the second object in the object map.

9.	 Once the brain object has been extracted, select the Manual tab.

10.	 To extract the ventricles, click the Add Object button. Change the 
Name to Ventricles and Color to Green. Select the Auto Trace 
tool.

11.	 Move to Transverse Slice 130 and set a seed point within the 
Ventricles.

12.	 Set the Threshold Minimum to 1 and the Threshold Maximum to 
48 (figure 4). If there are unconnected regions that should belong to 
the same object, click to set additional seed points.

13.	 To automatically advance the seedpoints to the next slice, set Auto 
Advance to Forward, then click Apply.

14.	 Click the Apply button until the ventricles are defined. If 
needed, click the Reset Seeds button and click to place 
new seed points inside the ventricles (figure 5).

15.	 To review the segmentation on the rendering, right click on 
the render window and select Transparency (figure 6). To 
rotate the rendering, click and drag with the middle mouse 
button.

16.	 To save the created object map for use in other Analyze 
modules, choose File > Save Object Map. Close the 
Volume Edit module before proceeding to the next 
exercise.

Volume Edit

Figure 6

Figure 4

Figure 5

Exercise 32
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Volume Edit: Adipose Tissue Segmentation Exercise 33

In this exercise we will review the segmentation of visceral and subcutaneous adipose tissue to demonstrate key Volume Edit functionality 
including; Edge Strength, Region Growing, and Object Separation. However, this application is one approach used for the segmentation and 
separation of fat pads in mice.   

1.	 Download the CLS_MouseFat.avw data set from www.
analyzedirect.com/data/CLS_MouseFat.zip. Use File > 
Load to load the data into Analyze.

2.	 Use the Process > Spatial Filters module to apply a 3 x 3 
x 3 median filter to the data set. See Exercise 27: Spatial 
Filters for instructions on applying a filter to a data set. 

3.	 Next select the filtered data set (CLS_MouseFat_Med) 
and open Segment > Volume Edit.

4.	 Click the Intensities button and adjust the Minimum and 
Maximum intensity values to improve display of 
fat and abdominal wall.

5.	 From the Edge Strength tab check the  ‘Use 
Edge Strength’ option. 

6.	 Set the Edge Strength Threshold to 63. Note 
that the abdominal wall is shown in red (figure 1).

7.	 Next select the Semi-Automatic tab and choose 
the Region Grow option. 

8.	 In the transverse orientation use the slider bar to move to 
slice 256. Click intra-abdominal fat then set the Threshold 
Minimum to 2230 and the Threshold Maximum to 2540 
(figure 2).

9.	 Click Extract Object.

10.	 Repeat to add any additional areas of adipose tissue.

11.	 In the Objects control panel rename Object_2 to VAT 

Figure 2

Figure 3

Figure 1

ftp://SWDL:download1@files8.cyberlynk.net/Data/CLS_MouseFat.zip
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(Visceral Adipose Tissue).

12.	 Click Add Object, change the name of the new object to SubQ 
(Subcutaneous Adipose Tissue) 

13.	 Select Object Separator. Click to set a seed point in a region of 
subcutaneous adipose tissue. Then click to set a second seed point 
in a region of visceral adipose tissue (figure 4). 

14.	 Click Separate. The two regions of adipose 
tissue will be broken into their respective sub-
compartments (figure 5).

15.	 Save the object map by selecting File > Save 
Object Map. 

16.	 Note that the VAT and SubQ volumes can 
be sampled using the Measure > Region of 
Interest module. For more information please 
refer to exercise 51: Region of Interest - 
Measuring Objects in Object Maps. 

17.	 Exit the Volume Edit module.

Volume Edit: Adipose Tissue Segmentation

Figure 4

Figure 5

Exercise 33
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Volume Edit: 4D Segmentation Exercise 34

Segmentation is often the precursor to other image analysis applications such as image measurement. Volume Edit provides a gamut of tools for 
a variety of segmentation tasks not only applicable to 2D-ROI and 3D-VOI measurement but also 4D-VOIs. In this exercise we will use the Volume 
Edit module to segment the left atrium in the heart using the Object Extractor tool over a series of 18 3-D volumes that span the entire cardiac 
cycle. The segmentation result can then be used for a number of applications such as calculation of blood volumes in the region over different 
stages of the cardiac cycle or cardiac ejection fraction.

1.	 Load the mouse dataset BeatVol from $:\BIR\images\
TutorialData directory. 

2.	 Use File > Load to load the data set into Analyze. 

3.	 Next select the BeatVol data set and open Segment > 
Volume Edit.

4.	 Note that there is an additional Volume control option.  
Use the Volume slider to navigate through all 18 volumes. 
Set the volume back to 1 when done. 

5.	 The “Segment All Volumes” option will be checked by 
default, with this option checked the semi-automatic 
segmentation task performed on the currently selected 
volume will be propagated to each volume in the series. 

6.	 Click on the Semi-Automatic tab and choose the Object 
Extractor option.

7.	 Set a seed point in the Left Atrium.  Set the Min 
Threshold to 154 and the Max Threshold to 255, then 
click Extract Object. The Object will be segmented in all 
18 volumes. Review the segmentation by moving through 
the Volume Slider.

8.	 Save the object map by 
selecting File > Save 
Object Map. 

9.	 Exit the Volume Edit 
module.

Figure 1
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Volume Edit: Cerebellum Segmentation Exercise 35

Segmenting structures from surrounding anatomy with a similar grayscale intensity can be difficult. This exercise will demostrate how to utilize the 
walls function in Volume Edit to make segmenting the cerebellum from the rest of the brain easier.

1.	 Load the MRI_EGV_Brain.avw from the the $:\BIR\images\TutorialData 
directory. 

2.	 Select the data set and open Segment > Volume Edit.

3.	 Adjust the intensity range by opening View > Intensities and lowering the 
Maximum value to 80.

4.	 Select the Walls tab, and check Define walls to limit semi-automated 
operations. In the options returned, set Draw Walls and Spline (figure 1).

5.	 In the Sagittal view navigate to slice 68. Start setting spline points between 
the cerebellum and the rest of the brain. Click Apply on the Walls panel after 
completing a spline, or hit A on your keyboard to apply the spline. 

6.	 Move forward several slices and define another spline. Repeat across the brain 
(figure 2). Figure 1

Figure 2

note Always define walls in the same manner. For example if defining from the front to the 
back of the brain make sure all walls for defined in this way. 
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Figure 4 Figure 5

7.	 Once complete, move back through the slices and 
review the walls. Add new walls if needed. 

8.	 Select the Semi-Automatic tab and select the Object 
Extractor option. Click in the cerebellum on a sagittal 
slice to set a seed point. 

9.	 Select a min threshold of 30 and a max of 69 (figure 3). 
Click Extract Object. 

10.	 Lock Object_2 and click Add Object. Set a seed point 
in the white matter on a spatially connected transverse 
slice, then click Extract Object. 

11.	 Change the name of Object_2 to Cerebellum and 
Object_3 to Brain.

12.	 Save the Object Map (File > Save Object Map) and 
open in Measure > Region of Interest to make 
measurements of the Brain and Cerebellum objects. 

13.	 Close the module before proceeding to the next 
exercise.

Volume Edit: Cerebellum Segmentation

Figure 3

Exercise 35
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Volume Edit: Lung Segmentation Exercise 36

In this exercise we will review lung segmentation from preclinical mouse data. We will cover additional segmentation and processing tools available 
in the module, including object separation and morphological operations dilation, erosion, and fill holes. 

1.	 Download the mouse dataset Mouse_Lungs from www.
analyzedirect.com/data. 

2.	 Unzip the data and then use File > Load to load the Mouse 
data set into Analyze. 

3.	 Next select Process > Spatial Filters to apply a 3 x 3 x 3 
median filter to the data set. See Exercise 27: Spatial Filters 
for instructions on applying a filter to a data set. 

4.	 Next select the filtered data set (Mouse_Lungs_Med) and 
open Segment > Volume Edit.

5.	 Click Add Object, change the name of the new object to 
Lungs. 

6.	 Next select the Semi-Automatic tab and choose Object 
Extractor (figure 1).

7.	 Using the slider under the transverse image move 
to slice 210, now click inside the lungs to set a 
seed point.  

8.	 Use the threshold slider to define a threshold range 
with a minimum of 1200 and maximum of 1550 
(figure 2). Then click the Extract Object button.

9.	 If necessary repeat the object extraction steps to 
add any missed regions to the Lung.

10.	 To separate the trachea from the lungs add a new 
object, click Add Object and name the object 
Trachea&Bronchi (figure 3).

Figure 2

Figure 1

Figure 3

www.analyzedirect.com/data
www.analyzedirect.com/data
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11.	 Next select Object Separator. 
Click on the trachea to set a 
seed point then click on the 
lungs to set a second seed 
point. Note you can click 
on either the 3-D rendering 
or the 2-D slices. Next click 
‘Separate’.

12.	 Review the separation results. 
Repeat the object separation 
steps to separate any 
remaining areas of the trachea 
from the lungs (figure 3).

13.	 Select the Trachea&Bronchi 
object in the Object list and 
then click the ‘Delete’ button to 
remove the object.

14.	 To obtain a total lung volume 
measurement it may be 
necessary to fill any holes in 
the lungs. To do this use the 
morphological tools in the 
Objects window. Select View > 
Objects, set Object to Lungs 
and then click on the Morph 
Objects button.

Figure 3

Volume Edit: Lung Segmentation Exercise 36
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Volume Edit: Lung Segmentation
15.	 In the Morph Objects window set the following parameters (figure 5):

•	 Objects to Lungs
•	 Operation to Dilate 

•	 Element Shape to Jack
•	 Element Size to 5 by 5 by 5

•	 Defined Object to Lungs

16.	 Click Morph. The Lungs object will be dilated. Now, set the following 
parameters (figure 6): 

•	 Objects set to Lungs
•	 Operation to Fill Holes 

•	 Fill Type to 3 pass 2D; Transverse; and 4-connected 
•	 Defined Object to Lungs

17.	 Click Morph. The Lungs object will be filled. 

18.	 Finally set (figure 7): 

•	 Objects to Lungs
•	 Operation to Erode
•	 Element Shape to Jack
•	 Element Size to 5 by 5 by 5

•	 Defined Object to Original

19.	 Click Morph. The Lungs object will be eroded. Click Done to 
dismiss the Morph Objects window.

20.	 Save the object map by selecting File > Save Object Map. 

21.	 Note that the lung volume can be measured using the Measure > 
Region of Interest module. For more information please refer to 
Exercise 55: Region of Interest - Measuring Objects in Object 
Maps. 

22.	 Exit the Volume Edit module.

Figure 4

Figure 5

Figure 6 Figure 7

Exercise 36
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Volume Edit: Advanced Segmentation Exercise 37

In this exercise we will review some of the additional tools and options in the Volume Edit module designed to enhance your segmentation 
capabilities.  The exercise will demonstrate the application of the Edge Strength and Walls tools to set 3D limits on the image data set. The 
exercise will then explore the Object Extractor, Object Separator, and Oblique Cutting options.   

1.	 Download the Cardiac_CT.avw data set from www.
analyzedirect.com/data. Unzip the file and then use 
File > Load to load the data set into Analyze.

2.	 Select the Cardiac_CT data set and open Segment > 
Volume Edit.

3.	 In the Edge Strength tab check the Use Edge 
Strength.

4.	 Set Edge Strength Threshold to 94 (figure 1). Note: The 
Edge Strength option allows users to mask the loaded 
volume with a threshold range of sobel filter gradients, 
aiding with the segmentation of objects. 

5.	 Next select the Walls tab. Check Define walls to limit 
semi-automated operations. Now select Draw Wall 
and then set Wall Type to Line (figure 2).

6.	 Using the slice slider below the transverse image, move 
to slice 138. Draw a line along the mitral valve between 
the left ventricle and left atrium (figure 3).

7.	 Now move to transverse slice 171. Draw another 
line along the mitral valve (figure 4). Note: Using the 
transverse slice slider move back to slice 138. Note 
that the wall defined between slice 138 and 171 has 
interpolated between the two positions over the slices 
in between. This wall will act as a 3D limit across the 
volume aiding with segmentation of the data. Move 
back to slice 171 before proceeding.  

8.	 In the object control panel click the Add Object button 

Figure 1

Figure 2

Figure 3 Figure 4
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(figure 5). 

9.	 Select the Semi-Automatic tab and choose the 
Object Extractor option. 

10.	 Using the Sagittal slice slider move to slice 228.

11.	 Click in the middle of the left atrium to set a seed 
point (figure 6). Set the following threshold range: 
Minimum: 235 and Maximum: 2213. 

12.	 Click Extract Object (figure 7). Note: The 3D 
limits specified by defining walls in the transverse 
orientation prevented the aorta from being included as 
part of this segmented object.  

13.	 Click the Add Object button and move to transverse 
slice 262. 

14.	 Click in the middle of the aorta to set a seed point 
(figure 8).  Note: The module remembers the previous 
threshold range set (if the seed pixel value is within 
the threshold range) and will automatically populate 
the minimum and maximum threshold values.  

15.	 Click Extract Object (figure 9).

16.	 To enable the transparency rendering view right-click 
on the rendering and select Transparency.

17.	 Click Add Object. 

Volume Edit: Advanced Segmentation

Figure 5 Figure 6

Figure 7

Figure 8

Exercise 37
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Volume Edit: Advanced Segmentation

Figure 9 Figure 10

Figure 11

18.	 Next select the Object Separator option.

19.	 On the rendering click to set a seed point on the aorta.

20.	 Then set a second seed point on the left ventricle below the 
aortic valve.

21.	 Now click Separate. The aorta will be split into two objects 
(figure 10).

22.	 Click Add Object. 

23.	 Now select the Browse tool. Using the middle mouse button 
(or the left-mouse button + CTRL key) rotate the rendering of 
the heart so you can clearly see the pulmonary vein.

24.	 Select the Oblique Cutting option and then click on the 
pulmonary vein. The Volume Edit interface will update to 
show the Oblique Cutting interface. Note: The oblique 
plane can be moved or rotated interactively using the 
orthogonal images or the rendering.

25.	 Right-click in the oblique image and select the 
Dimensions/Increment option. Set the Width to 50 and 
the Height to 50, then click Done.

26.	 Click the Cut button in the manual control panel to 
separate the pulmonary vein into the new object (figure 11).

27.	 Click Browse to return to the regular Volume Edit interface.

28.	 Select File > Save Object Map to save your work. 

29.	 Close the Volume Edit module. 

Exercise 37
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Volume Edit: Liver Segmentation Exercise 38

Manual segmentation is often necessary when semi-automatic segmenation fails. While manual segmentation can be time consuming, Analyze has 
tools to speed up segmentation time. The propagate regions option uses shaped-based interpolation to extend the definition a region to slices on 
which it was not defined. For example, if the user defined a region on every third slice, the tool could be used to fill in the region on the slices in 
between.

1.	 Load the CT_Liver.avw data set from the $:\BIR\images\
TutorialData directory.

2.	 Open the Volume Edit module (Segment > Volume Edit).

3.	 Click on the Intensities button and adjust the minimum and 
maximum intensities.

4.	 Use the slice slider bar underneath the Coronal view and 
navigate to slice 100

5.	 Select the manual tab and then the Spline Edit tool. Check the 
Smart Edge option and set the Sensitivity to 3. 

6.	 Begin clicking around the outside of the liver on the Coronal 
slice 100 (figure 1). Once finished double click to close the 
spline. 

7.	 Once the spline has been closed and the points are correctly 
set, click Apply.

8.	 Navigate to Coronal slice 125. Use spline edit to define the liver 
and click Apply.

9.	 Repeat the same process for Coronal slice 150 & 175 (figure 2).

Figure 1

Figure 2

note - Control points can be moved using the middle mouse button (or 
   <Shift> + Left mouse button).
- To add a control point click with the left mouse button.
- To delete a control point, right click on the control point and select        
   “Delete Control Point”.
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Volume Edit: Liver Segmentation 
10.	 Select the Semi Automatic tab and click on the 

Propagate Objects option.

11.	 Set the Propagation Type to the Current Object 
and select Coronal.

12.	 Click Propagate.

13.	 The module will use shape-based interpolation 
to generate regions on the slices between the 
defined regions (figure 3).

14.	 Close the module before proceeding to the next 
exercise. 

Figure 3

Exercise 38
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Morphology Exercise 39

The Morphology module applies 1-D, 2-D, or 3-D mathematical morphological transformations and object topology operations to a data set. This 
exercise will demonstrate the morphological segmentation tools available in the module by showing how to segment the brain from an MRI data 
set.

1.	 Load the MRI_3D_Head.avw data set from the $:\BIR\images\TutorialData directory.

2.	 Open the Morphology module (Segment > Morphology).

3.	 From the Generate menu, open the Slice tool. Move the slice slider to slice 130.

4.	 Open the Step Editor window (Generate > Step Editor) (figure 1).

5.	 Click the Threshold button. In the Step 1: Threshold window returned, set the 
Threshold Min to 65. Click Threshold Volume. In the window returned, select 
Change a Copy of the Loaded Volume.

6.	 Select Generate > Display Section(s) > Current to review that data.

7.	 Select File > Save Volume. Save the volume as MRI_3D_Head_bin.

8.	 Click the Erode button. In the Step 2: Erode window, change the Element 
Depth to 3 and change the value Iterations to 2. Click Erode Volume (figure 2).

9.	 In the Step Editor window, click Transform Volume. A dialogue box will be 
returned, select Yes.

10.	 Click Connect. Change Max. No. of Components to 1. Click Connect Volume.

11.	 In the Step Editor window, click Conditional Dilate. In the Conditional window, 
change Element Depth to 3 and change Iteration to 1. Next load the conditional volume by 
clicking the Volume button. Use the window returned to select the MRI_3D_ Head_bin.avw 
data set saved in step 7. Press the Cond. Dilate Volume button.

12.	 To view your segmentation, select Generate > Display Section(s) > Current (figure 3).

13.	 The binary segmentation is available in the Analyze workspace. To obtain a suitable volume 
for further analysis multiply the binary volume by the input grayscale volume using the 
Image Calculator or Image Algebra modules.

14.	 When you are finished reviewing, close all windows related to the Morphology module 
before proceeding to the next module.

Figure 2

Figure 3

Figure 1

note Notice the left side of the Step Editor window; as operations are selected from below the Morph Operations, 
the sequence of steps is maintained on the left.
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Watershed: Automated Segmentation Exercise 40

The goal of this exercise is to demonstrate how to automatically strip the skull from in a T1- or T2-weighted MRI scan.

1.	 Load the MRI_3D_Head.avw data set from the $:\BIR\images\TutorialData 
directory.

2.	 Open the Watershed module (Segment > Watershed).

3.	 The Watershed module default parameters usually allow for a successful 
segmentation of the brain. Check the Always Display option and view the red pixels 
that define the ‘Pre-Fill’ level on different slices and orientations. Do not change the 
Pre-Fill Value (49).

4.	 Click Watershed Segment Volume to initialize the automatic segmentation.

5.	 After the automatic segmentation process has completed, the Results tab is 
automatically selected (figure 1). Each segmented object will appear as a different 
random color in the image display.

6.	 With the Render Selected Object option selected, click on the object that 
represents the brain in the image display.

7.	 The Render Tool will automatically be returned (figure 2), allowing you to review the 
segmented objects from difference orthogonal orientations. You can also click and 
drag the rendering to a new view in the Render Tool image display.

8.	 Select the Create Masked Volume from Selected Object option from the Results 
tab. Then, click again on the object that represents the brain. The Compare window 
that appears allows you to review the original and segmented volume side-by-side, 
slice-by-slice in different orthogonal views.

9.	 The File menu provides options to save the segmented volume, the masked volume, 
and create an object map of the segmented object.

10.	 Choose File > Save Masked Volume. In the window returned, set Destination to 
Analyze Workspace and then click Save Volume. The object clicked on in step 8 after 
selecting ‘Create Masked Volume from Selected Object’ will be saved to the Analyze 
workspace. Click Done to dismiss the Save Masked Volume window.

11.	 Close all windows before proceeding to the next exercise.

Figure 1

Figure 2
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Multispectral Classification Exercise 41

The goal of this exercise is to demonstrate the use of the Scattergram tool in the Multispectral Classification module to illustrate the various 
supervised classifiers in the multispectral measurement space.

1.	 Load the MRI_multi.avw data set 
from the $:\BIR\images\TutorialData\
MultiSpectralTutorial directory. This file 
contains a spatially co-registered MRI T1 
and T2 volume of the same patient.

2.	 Open the Multispectral Classification 
module (Segment > Multispectral 
Classification).

3.	 Open the Scattergram window (Samples 
> Scattergrams).

4.	 In the Scattergram window (figure 1), move 
the Slice slider bar to slice 14. The T1 and 
T2 sections are displayed side-by-side 
along with the scattergram of the pixels. 
To increase the image display size, change 
Single to Double in the drop-down menu 
next to the ‘Slice’ slider bar.

5.	 Select the Closed Trace tool and define a small region of white 
matter (central brain tissue) as class 1 by drawing on the image 
display. The paired values found in this region are colored red in 
the scattergram display and on the image displayed in the main 
Multispectral Classification window (figure 2).

6.	 Choose ‘class 2’ from the Classes drop-down menu before starting 
the trace. Select the Curved Line tool and define a small region of 
grey matter (peripheral brain tissue) as class 2. The paired values 
will show as green in the scattergram and in the image display.

7.	 Select the Closed Trace tool and define a small region of 
cerebrospinal fluid (in the central ventricles) as class 3.

Figure 2

Figure 1
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8.	 Click Classify Images. The Gaussian Scattergram 
Classifier window will automatically be returned (figure 3), 
click Classify. Click Done to dismiss the window.

9.	 In the main Multispectral Classification window, the 
classified image will be returned (figure 4).

10.	 Choose Scattergram & Classified from the drop-down 
menu below the far right pane of the Scattergram 
window to view the Gaussian class boundaries derived 
from the samples (figure 5).

11.	 By selecting classifiers other than ‘Gaussian Cluster’ in 
the Scattergram window before clicking Classify Images, 
other supervised classifiers can be demonstrated on the 
same samples.

12.	 Close the Multispectral Classification module before 
proceeding to the next exercise.

Figure 3

Figure 5

Figure 4

Multispectral Classification Exercise 41
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Object Extractor: Automated Brain Segmentation Exercise 42

The Object Extractor module applies thresholding, morphology erosion and dilation, and region growing steps in an attempt to automatically 
segment an object within a volume. This exercise will demonstrate how to use this module.

1.	 Load the MRI_3D_Head.avw data set from the $:\BIR\images\TutorialData 
directory.

2.	 Open the Object Extractor module (Segment > Object Extractor).

3.	 Open the Define Region window (Generate > Define Region) to begin the 
segmentation process.

4.	 To define an auto trace on any slice of the volume, first specify a starting slice using 
the ‘Slice’ slider bar. Slice 141 is an excellent starting point for this data set. Note 
that the orientation can be changed using Target Slice directly below the slider bar.

5.	 In order to define a threshold range for the auto trace, a seed point must be set. 
Position the cursor near the center of the brain and click to set a seed point.

6.	 The Define Region window will automatically update (figure 1) to display auto trace 
parameters. Use the double-ended slider bar now available to set the Threshold 
Minimum to 49 and the Maximum to 140.

7.	 Click Extract Object to start the object extraction process. The grayscale copy of 
the extracted object will automatically be saved to the Analyze workspace.

8.	 Once the process is complete, a rendering of the extracted object will be displayed 
in the main Object Extractor window. The Render Tool will also automatically be 
returned, allowing you to view the object from different orientations (figure 2).

9.	 The resulting extraction can be further examined in the Compare window (Generate 
> Compare). The Compare window will allow the user to compare the original and 
segmented volume slice-by-slice.

10.	 If the extraction is not satisfactory, the data may be re-segmented by clearing the 
regions in the Define Region window (Generate > Define Region) and selecting a 
new seed point and threshold range.

11.	 Close the Object Extractor module before proceeding to the Additional Tasks.

Figure 2

Figure 1
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Figure 1

Figure 2

Figure 3

As introduced in earlier exercises, an object map is a special image file used by Analyze to partition and identify structures as belonging to a 
particular segmented object. Voxels in the image volume correspond directly, on a one-to-one basis, with a voxel in the object map, whose 
value assigns the voxel to a particular segmented object. Since object map files can also be loaded into other Analyze modules, the same 
objects within an image volume can be referenced for a variety of purposes (see Exercise 47: Region of Interest Measuring Objects in Object 
Maps). This exercise will demonstrate how to create an object map in Object Extractor.

1.	 Select the MRI_3D_Head.avw data set loaded in the Analyze 
workspace and open the Object Extractor module (Segment 
> Object Extractor).

2.	 Open the Define Region window (Generate > Define Region) 
and set the Target Slice to 141.

3.	 Click inside the brain to set a seed point. Set the Threshold 
Minimum to 49 and the Maximum to 140.

4.	 Click Extract Options and set the Result to Object (figure 1). 
A dialog box will be returned asking if you would like to create 
an object map, click Yes (figure 2). Click Done to dismiss the 
Extract Options window.

5.	 In the Define Region window, click Extract Object to start the 
object extraction process.

6.	 Once the extraction process is complete the object will be 
displayed in the Render Tool (figure 3), allowing you to view the 
object from different orientations.

7.	 The object map will not be automatically saved, if you wish to 
save the object map choose File > Save Object Map.

8.	 Close the Object Extractor module. To learn how to create a 
binary object with the Object Extractor proceed to the next 
Additional Task.

Object Extractor: Creating an Object Map Exercise 42.1
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Figure 1

Occasionally it is necessary to save the segmented object as a binary object, as opposed to a grayscale object like in the first part of this 
exercise. This additional task will demonstrate how to achieve this.

1.	 Select the MRI_3D_Head.avw data set loaded in the Analyze 
workspace and open the Object Extractor module (Segment 
> Object Extractor).

2.	 Open the Define Region window (Generate > Define Region) 
and set the Target Slice to 141.

3.	 Click inside the brain to set a seed point. Set the Threshold 
Minimum to 49 and the Maximum to 140.

4.	 Click Extract Options and set the Result to Binary (figure 1). 
Click Done to dismiss the Extract Options window.

5.	 In the Define Region window, click Extract Object to start the 
object extraction process.

6.	 Once the process is complete, a rendering of the extracted 
object will be displayed in the main Object Extractor window. 
The Render Tool will automatically be returned again, 
allowing you to view the object from different orientations. 
The segmented binary brain will be automatically saved to 
the Analyze workspace and can now be used with any other 
Analyze module.

7.	 Close the Object Extractor module before proceeding to the 
next Additional Task.

Object Extractor: Creating a Binary Object Exercise 42.2
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Figure 1

Figure 2

The Object Extractor module now provides the option to automatically remove the brain stem from your segmented brain. This task will 
demonstrate how to segment and remove the brain stem.

1.	 Select the MRI_3D_Head.avw data set loaded in the Analyze workspace 
and open the Object Extractor module (Segment > Object Extractor).

2.	 Open the Define Region window (Generate > Define Region) and set the 
Target Slice to 141.

3.	 Click inside the brain to set a seed point. Set the Threshold Minimum to 49 
and the Maximum to 140.

4.	 Click Extract Options and set the Remove Stem option to On (figure 1). 
Click Done to dismiss the Extract Options window.

5.	 In the Define Region window, click Extract Object to start the object 
extraction process.

6.	 Once the process is complete, a rendering of the extracted object will 
be displayed in the main Object Extractor window. The Render Tool will 
automatically be returned again, allowing you to view the object from 
different orientations. The segmented grayscale brain will be automatically 
saved to the Analyze workspace and can now be used with any other 
Analyze module.

7.	 Close the Object Extractor module before proceeding to the next exercise.

Object Extractor: Automatic Brain Stem Removal Exercise 42.3
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Object Extractor: Extracting Multiple Objects Exercise 43

The Object Extractor module supports the creation of multi-object object maps. This exercise will demonstrate the segmentation  
and separation of the lungs.   

1.	 Load the CT_Lungs.avw data set from the $:\BIR\images\
TutorialData directory.

2.	 Open the Object Extractor module (Segment > Object Extractor).

3.	 Open the Define Region window (Generate > Define Region) to begin 
the segmantation process.

4.	 To define an auto trace on any slice of the volume, first specify a 
starting slice using the ‘Slice’ slider bar. Slice 104 is the default slice, 
and it is an good starting point for this data set.

5.	 Position the cursor near the center of the left lung and click to set a 
seed point.

6.	 The Define Region window will automatically update (figure 1) to 
display auto trace parameters. Use the double-ended slider bar now 
available to set the Threshold Minimum to 18 and the Maximum to 
99.

7.	 Click the Extract Options button, and set the Result to Object (figure 
2), select Yes in the window returned.

8.	 In the Define Regions window, click Extract Object to start the object 
extraction process. The left lung will be extracted and saved as the 
object called ‘Extracted’. The object will appear red.

9.	 Open the Define Regions window again, when opened click the Clear 
Regions button. Next, click in the right lung to set a seed point, set the 
Threshold Minimum to 18 and the Maximum to 104.

10.	 Click Extract Object again. The right lung will be extracted and saved 
as the object called Extracted (2), the object will appear green. In the 
main Object Extractor module you will see both lungs (figure 3).

Figure 2

Figure 3

Figure 1
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11.	 The render window will now display both lungs in 3D (figure 4).

12.	 To change the name and color of each object, go to the Objects window 
(View > Objects). Set Control By to Attribute, and from the drop down menu 
select the Name and Color attribute options (figure 5).

13.	 To save the object map for use in other modules, select File > Save Object 
Map.

14.	 Close all windows related to the Object Extractor module before proceeding to 
the next exercise.

Figure 4

Figure 5

Object Extractor: Extracting Multiple Objects Exercise 43



Analyze 12.0 Training Guide 105

Surface Extractor: Polygonal Surface Extraction Exercise 44

Polygonal surface extraction is the process of converting an object in the voxel-based volume to a representation of the surface of the object, 
expressed as sets of vertices and polygons. This conversion must optimally extract a representative surface, with as much detail as possible, 
but do so with as few vertices and polygons as possible. This exercise will use the Adapt/Deform algorithm to perform such an optimal surface 
extraction. Often this surface extraction is a precursor to using the surface with other applications, such as CAD/CAM modeling, rapid prototyping 
(model building), and finite element analysis.

1.	 Load the MRI_3D_Head.avw data set from the $:\BIR\images\TutorialData 
directory.

2.	 Open the Surface Extractor module (Segment > Surface Extractor).

3.	 Choose File > Load Object Map and load the MRI_3D_Head.obj object map.

4.	 Open the Extraction Parameters window (Generate > Extraction).

5.	 Click Objects at the top of the Extraction Parameters window (figure 1). In the 
window returned, leave the Brain set to On and set all other objects 
to Off (figure 2). Click Done to dismiss the window.

6.	 Create a polygonal surface of the ‘Brain’ object using the 
Adapt/Deform algorithm with the default parameters. With the 
AdaptDeform tab selected click Extract.

7.	 A dialog box will be returned stating the number of polygons 
generated. Note the number of polygons (approximately 37,258), 
then click Done.

8.	 To create a rendering of the surface model, choose Generate > Render. A 
surface map will automatically be created for the ‘Brain’ surface, and the 
Surfaces window returned. The rendering will be displayed in the main 
Surface Extractor window (figure 3).

9.	 In the Extraction Parameters window change the Cube Edge Size to 5 
and rebuild the surface by clicking Extract. Note, the number of polygons 
generated (approximately 12,261), then click Done.

10.	 Choose Generate > Render to view the extracted surface with the new 
parameters (figure 4). Increasing the ‘Cube Edge Size’ will smooth the 
surface, reducing the number of voxels considered when generating the 
initial surface estimate, which reduces the polygon count.

Figure 1
Figure 2

Figure 3 Figure 4
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11.	 Click Reset in the Extraction Parameters window to restore the default 
parameters (‘Cube Edge Size’ of 3).

12.	 Click Advanced and change the Time Step to 0.5. Click Done to dismiss the 
window.

13.	 Rebuild the surface by clicking Extract in the Extraction Parameters window. 
Note the number of polygons generated (approximately 37,258), then click 
Done.

14.	 Choose Generate > Render to view the extracted surface with the new 
parameters. Increasing the ‘Time Step’ causes the surface extraction to reach 
equilibrium faster, producing a smoother surface without altering the polygon 
count. When the opposite changes are made, the surface will conform to the 
voxel surface better, resulting in a rougher, more “voxelated” surface.

15.	 Decreasing the Surface Force and increasing the Spring Constant (also 
‘Advanced’ options) smooths the surface without altering the polygonal count 
by forcing the polygons to bridge small variations in the voxel surface (the 
polygons’ attraction to the surface is reduced and they become harder to bend).

16.	 Choose File > Save Surface > To File to save the extracted surface to disk.

17.	 In the Save Surface window returned (figure 6) you can select from the following 
surface description formats in the Format drop-down menu: Alias (.obj), 
Autocad (.dxf), Compressed Iges (.iges), Iges (.iges), Inventor (.iv), Patran (.out), 
Ply(.ply) Poly (.poly), 3D Systems (.stl), Binary 3D Systems (.stl), Vrml (.wrl).

18.	 Close the Surface Extractor module. To learn about extracting the surface of a 
binary data set, complete the following Additional Task.

Figure 5

Figure 5

Surface Extractor: Polygonal Surface Extraction Exercise 44
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1.	 Load the MRI_3D_Brain_Bin.avw data set from the $:\BIR\images\
TutorialData directory.

2.	 Open the Surface Extractor module (Segment > Surface Extractor).

3.	 Open the Extraction Parameters window (Generate > Extraction).

4.	 With the AdaptDeform algorithm tab selected, click Extract.

5.	 Note the number of polygons generated (approximately 37,504) and choose 
Generate > Render to view the extracted surface (figure 1).

6.	 Close the Surface Extractor module before proceeding to the next exercise.

Figure 5

Surface Extractor: Extracting a Binary Data Set Exercise 44.1

Supported Surface File Formats

	 Polygonal Formats

Alias Wavefront 			   (.obj) Read and Write
Autocad 				    (.dxf) Read and Write
IGES 				    (.iges) Write only
Compressed IGES 		  (.iges) Write only
Inventor 				    (.iv) Write only
Patran 				    (.out) Write only
Poly 				    (.poly) Read and Write
Binary 3D Systems			  (.stl) Raad and Write
VRML 				    (.wrl) Write only

	 Contour Formats

HP 3D 				    (.hpgl) Write only
IGES 				    (.iges) Write only
Compressed IGES 		  (.iges) Write only
Pogo 				    (.slc) Read and Write
3D Systems Stereolithography 	 (.slc) Read and Write
ASCII Columns 			   (.txt) Read and Write
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Surface Extractor: Contour Surface Extraction Exercise 45

Contour surface extraction is the process of converting an object in the voxel-based volume to a representation of the surface of the object, 
expressed as a series of stacked contours. This surface extraction is a precursor to other applications, such as CAD/CAM modeling, rapid 
prototyping (model building), and finite element analysis. This exercise demonstrates how to use the Contours algorithm.

1.	 Load the MRI_3D_Head.avw data set from the $:\BIR\images\TutorialData 
directory.

2.	 Open the Surface Extractor module (Segment > Surface Extractor).

3.	 Choose File > Load Object Map and load the MRI_3D_Head.obj object map.

4.	 Open the Extraction Parameters window (Generate > Extraction).

5.	 Click Objects at the top of the Extraction Parameters window (figure 1). In the 
window returned, switch the Ventricle to On and set everything else Off. Click 
Done to dismiss the window.

6.	 Create a contour surface of the ‘Ventricle’ object using the Contours algorithm 
with the default parameters. Select the Contours tab and click Extract.

7.	 A dialog box will be returned stating the number of slices for which contours 
were generated. Note the number of slices used (60), then click Done.

8.	 To create a rendering of the extracted contour model, choose Generate > 
Render.

9.	 In the Extraction Parameters window, click Advanced in the ‘Contours’ tab. 
Check the Subvolume Extraction option and click Done to dismiss the 
window (figure 2).

10.	 Rebuild the contour surface by clicking Extract in the Extraction Parameters 
window. Note the number of slices used (108). This resamples and reformats 
the object and thus changes the number of slices.

11.	 Choose Generate > Render to create a rendering of the extracted contour 
model (figure 3).

12.	 Close the Surface Extractor module before proceeding to the next exercise.

Figure 3

Figure 1

Figure 2
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2D Registration Exercise 46

The 2D Registration module determines geometric transformation parameters which can be used to align 2D images, section to section by 
matching common contours or by matching sections to a single base slice. This exercise will demonstrate how to do this using the 2D Registration 
module to align a series of misaligned 2D slices.

1.	 Load the Spinal_Cord data set from the $:/BIR/images/TutorialData 
folder.

2.	 Open the 2D Registration module (Register > 2D Registration).

3.	 Open the Cursor Link Tool (Tools > Cursor Link).

4.	 Choose a Blend from the right-click menu in the upper right pane.

5.	 To review the data slice by slice, use the Match Section slider bar.

6.	 If required, slice data can be manually adjusted using the manual adjust 
control operations.

7.	 The % Base Image allows the combined image display (upper right 
pane) to fade between the base and match image.

8.	 Open the Control window (Generate > Control).

9.	 Choose between a Sequential or Single reference registration mode 
(figure 2):

Sequential: each slice will register sequentially to its neighbor (ie 
slice 2 to slice 1, slice 3 to slice 2, etc.)

Single Reference: will register each slice to a 
single base slice (defined with the To Section 
slider).

10.	 The Register Section and Thru slider bars allow 
users to determine a range of slices to be registered 
(ie slices 10-20 only).

11.	 Set the registration mode to Sequential, then click 
Done.

Figure 2

Figure 1
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12.	 Open the Voxel Match window (Generate > Voxel Match), expand 
the Threshold, Sample Region and Search Parameters options 
(figure 3).

13.	 Check the Show Thresholding option the image, the cursor link 
tool will update converting the images to binary representations. 
Only voxels displayed as white will be considered for the 
registration.

14.	 Set the Minimum threshold value to 5 to eliminate background 
noise. Then uncheck the Show Thresholding option.

15.	 The Sample Region option will allow for defining a region to 
consider for registration. See the X Minimum to 69 and the X 
Maximum to 333. Then set the Y Minimum to 33 and the Y 
Maximum to 237. Reset the Min/Max X and Y values before 
proceeding. Note the region is defined on the blended and match 
image (figure 4). 

16.	 The Search Parameters option allows users to adjust the X and Y 
Translation range, the Z Relation range and the X and Y Scaling 
range.

17.	 Click Register. Select Generate > Transform Slices, set the 
Destination to Analyze Workspace, then click Go. The data will be 
transformed and saved to the Analyze workspace.

18.	 Compare the input and output data sets to see the effect of the 
registration on the data.

Figure 3

Figure 4

2D Registration Exercise 46
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2D Non-Rigid Registration Exercise 47

The 2D Non-Rigid Registration module applies local Normalized Mutual Information (NMI) image registration in a grid of subregions. The optimized 
local registration transformations are then interpolated across the image to effect a continuous non-rigid transformation. This exercise will 
demonstrate how to register two adjacent sections to correct for the difference stretching forces each section has been subjected to.

1.	 Load the AdjacentSections data set from the C:/BIR/images/TutorialData 
folder.

2.	 Open the 2D Non-Rigid Registration module (Register > 2D Non-Rigid).

3.	 Open the Control Window (Generate > Control) (figure 1). Two Registration 
Modes are provided, Sections or Slabs.

•	 Sections: allows for each image to be non-rigidly registered to the next.

•	 Slabs: registration will only be performed at Interfaces between slabs, 
during transformation the non-rigid transformation is relaxed through the 
slab.

4.	 Set the Registration Mode to Sections. You can now choose between a 
Sequential or Single Reference registration.

•	 Sequential: specifies that each section will register sequentially to its 
neighbor.

•	 Single Reference: will register each slice to one 
base slice, the To Section slider is used to select 
the base.

5.	 Select Sequential (figure 2). Do not close the 
Control window.

6.	 Open the Cursor Link tool (Tools > Cursor Link). 
The Cursor Link window displays two sections; the 
Base and Match, in their current registration, as 
well as the two sections overlaid. Right click in the 
overlay window and select a Blend option from the 
Blend Mode menu.  

Figure 2

Figure 1
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7.	 By default, the Match section displays the current minimum region grid (the 
grid of subregions the local NMI is applied to), shown in green. Note there are 4 
regions, to adjust the region size use the Minimum Region Size X and Y sliders 
To increase the number of regions from 4 to 9, set the X slider to 112 and the Y 
slider to 119.

8.	 Note the orange box in the overlay window shows the current selected region. 
To switch this on in the Base and Match windows right-click and select the 
Selected Region option (figure 3).

9.	 Manual transformations and rotations can be applied to the current selected 
region in the Match image using the Manual Adjustment buttons. Because the 
regional displacements are interpolated across the image, some transformations 
may also affect adjacent areas of the image. The Resolution options (Coarse, 
Medium or Fine) below the Manual Adjustment buttons control the amount of 
displacement. Note, Fine resolution is a one pixel translation or one degree 
rotation, Coarse is approximately ten.

10.	 Click on the Non Rigid Parameters button.

11.	 In the Non-Rigid Match window (figure 4), review the following options:

•	 Threshold: Check the Show Thresholding option and note the update 
in the image display as you adjust the threshold range. Only voxels 
displayed as white will be considered for the registration.

•	 Samples: specifies the minimum and maximum sampling density.

•	 Process: these options set limits of confidence on the registration 
procedure.

12.	 To Register the sections sequentially click the Register All Sections 
button in the Control window.

13.	 After registration is complete select Generate > Transform Slices from 
the main 2D Non-Rigid Registration window. In the Transformation 
window returned, set the Destination to Analyze Workspace and set the 
Interpolation option to Linear (default), next click GO. The transformed 
image data will be saved to the Analyze workspace.

14.	 Close the 2D Non-Rigid Registration module.

Figure 3

Figure 4

2D Non-Rigid Registration Exercise 47
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15.	 Review the original data and then the registered data (Match2D_out) using the Multiplanar Sections module. Observe the difference in 
the slice data between the two data sets, specifically slices 2 and 3 in the registered data set (figure 6).

Figure 6

Figure 5

2D Non-Rigid Registration Exercise 47
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3D Surface Registration Exercise 48

Surface matching is fast and robust, even in the presence of image noise and incomplete overlap of the image volumes. Both volumes must 
contain common objects, which must be explicitly segmented from the grayscale image data and saved as a grayscale or binary image. A surface 
is extracted from both a “base object” and a “match object” that are preprocessed from the base volume and match volume, respectively. This 
exercise will demonstrate how to achieve an optimal registration of two 3D volumes based on corresponding surfaces.

1.	 Load the Edited_MRI_Head.avw and the Edited_
PET_Head.avw data sets from the $:\BIR\images\
TutorialData directory.

2.	 Select the Edited_MRI_Head.avw data set, then while 
holding down the <Ctrl> key, select the Edited_PET_
Head.avw data set.

3.	 Open the 3-D Surface Registration module (Register 
> 3-D Surface).

4.	 Select File > Input/Output Ports to view the import 
and output ports at the bottom of the main 3-D Surface 
Registration window. Make sure that Edited_ MRI_Head 
is the base volume, and Edited_PET_Head is the match 
volume.

5.	 Open the Blend window (Generate > Blend). Set the 
Blend Type to Green-Red.

6.	 Examine the combined images to determine if they 
need to be registered.

7.	 Select Generate > Register to register the two 
volumes.

8.	 Select File > Save Transformed and save the 
transformed PET to the Analyze workspace.

9.	 Close the 3-D Surface Registration module before 
proceeding to the next exercise.
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3D Voxel Registration Exercise 49

The 3-D Voxel Registration module is an implementation of the Normalized Mutual Information algorithm and allows users to spatially register two 
volume images. The module contains several unique and powerful algorithms that will allow the precise alignment of 3-D data to be achieved, both 
quickly and efficiently. This exercise will demonstrate how to register two images of different modalities.

1.	 Load both the MRI_Head.avw and PET_Head.avw data sets from 
the $:\BIR\ images\TutorialData directory.

2.	 In the main Analyze workspace, first select the MRI_Head data set. 
Then, while holding down the <Ctrl> key, select the PET_Head data 
set (resulting in both being selected).

3.	 Open the 3-D Voxel Registration module (Register > 3-D Voxel).

4.	 Choose File > Input/Output Ports to ensure that MRI_Head is 
assigned as the ‘Base Volume’ and PET_Head is assigned as the 
‘Match Volume’.

Main Interface Features

5.	 The main interface contains nine image display panes (figure 1).

•	 First Column: Displays the ‘Base’ volume (MRI_Head)

•	 Last Column: Displays the ‘Match’ volume (PET_Head) pre-
scaled to the size of the base volume

•	 Middle Column: Displays the base and match volumes fused 
together

•	 Rows: Display the volumes in the transverse, coronal, and 
sagittal orientations

6.	 By default, the volumes are displayed with cubic voxels. To turn off 
the cubic display press the Toggle Cubic PowerBar button. For this 
exercise leave cubic display on.

Figure 1
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7.	 Open the Blend window (Generate > Blend). The Blend window provides different 
settings to help visually evaluate the registration. Experiment with the different blend 
options (figure 2) and then click Done to dismiss the window.

8.	 The crosshair in each of the image display panes can be used to move through 
the volumes. When the crosshair is moved in any of the panes, the other panes 
automatically update to display the same volume coordinate. Note, the base and 
match coordinates are reported at the bottom of the window.

9.	 Right-click on any of the image display panes to view options for controlling individual 
tiles, reference lines, image sizes, annotations, and interactivity.

Registration

10.	 For this exercise, no parameters need to be changed for a successful registration, 
the default settings are appropriate. Press the Register PowerBar button or choose 
Generate > Register.

11.	 After registration is complete you will see that the PET volume has been scaled, 
rotated, and translated to match exactly the sagittal MRI. To evaluate the registration, 
move the crosshair in any of the panes and change the ‘Blend’ type to ‘Average’.

12.	 To view the current transformation matrix open the Matrix Tool (Tools > Matrix). You 
may manually enter rotations, translations, and scaling to the matrix by selecting an 
option and increment (figure 3). You may also save the current matrix as an ASCII 
floating-point file or load a previously saved matrix.

13.	 You may also use manual correction buttons in the Manual tool (Tools > Manual) to 
incrementally change the registration matrix. The buttons move the match volume 
section in the directions indicated, and then adjust the 3-D matrix depending upon the 
orientation selected.

3D Voxel Registration

Figure 2

Figure 3

Exercise 49
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3D Voxel Registration
Saving Transformed and Fused

14.	 To save a copy of the transformed match volume (PET_Head), choose 
File > Save Transformed; the transformed volume can be saved to 
disk or to the main Analyze workspace (figure 4).

15.	 To save the fused volume, choose File > Save Fused; the fused 
volume can be saved to disk or to the main Analyze workspace.

16.	 Close the 3-D Voxel Registration module before proceeding to the 
Additional Task. Figure 6

Exercise 49
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1.	 Select the MRI_Head.avw data set. Then while holding down the <Ctrl> key, select 
the PET_Head.avw data set (resulting in both being selected).

2.	 Open the 3-D Voxel Registration module (Register > 3-D Voxel).

3.	 To access the Adjust Scale tool, open the Manual Registration tool from the Tools > 
Manual menu (figure 1). Check the Adjust Scale option, the Manual Registration tool 
will update with X, Y, and Z scale tools.

4.	 Adjust the scale of the Match data up and down in each orientation by click on the 
arrow up and arrow down keys. Note the display of the Match data each time the 
scale is adjusted.

5.	 Close all windows associated with the 3-D Voxel Registration module before 
proceeding to the next exercise.

Figure 1

3D Voxel Registration: Manual Scale Adjustment Exercise 49.1

The Manual Registration tool in both the 3-D Voxel and Surface Registration modules now provides the ability for users to manually adjust the 
scale of the Match data prior to registration. This task will demonstrate how to access and use the new Adjust Scale tool.
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3D Voxel Registration: Mutual Information Exercise 50

This exercise will demonstrate how to adjust a 3-D registration starting position to achieve an optimal registration of two 3-D volume images.

1.	 Load both the Register_MRI_Base.avw and Register_
MRI_Match.avw data sets from the C:\BIR\images\
TutorialData directory.

2.	 In the Analyze workspace, first select the Register_MRI_
Base data set. Then, while holding down <Ctrl> select 
the Register_MRI_Match data set (resulting in both being 
selected).

3.	 Open the 3-D Voxel Registration module (Register > 3-D 
Voxel).

4.	 Choose File > Input/Output Ports to ensure that 
Register_MRI_Base is assigned as the ‘Base Volume’ and 
Register_MRI_Match is assigned as the ‘Match Volume’.

5.	 Open the Blend window (Generate > Blend). Select the 
Red-Green blend and then click Done. The ‘Red-Green’ 
blend option will help evaluate the registration (figure 1).

6.	 Press the Register PowerBar button or choose Generate 
> Register.

7.	 Examine the center ‘Fused’ column of the main module 
window (figure 1). As you can see, the registration is not 
acceptable.

Figure 1
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3D Voxel Registration: Mutual Information
Manual Adjustment

8.	 Since the registration is not acceptable, manually adjust the starting point 
of the registration. Open the Manual tool (Tools > Manual).

9.	 Click Reset Matrix in the Manual tool (figure 2), this will reset the match 
volume to the original starting position.

10.	 Now, using the Manual tool options, move the match volume to a better 
starting position and press Register.

11.	 If the registration is still not acceptable, return to the Manual tool and 
click Reset Matrix again.

12.	 Now, select the Coarse adjustment option and press the down arrow 
button once. 

13.	 Change the orientation from coronal to sagittal by selecting the S-cube 
and then press the right arrow button once.

14.	 Press Register. The volumes should now register correctly.

Saving

15.	 To save the transformed match volume (Register_MRI_Match), choose 
File > Save Transformed; the transformed volume can be saved to disk 
or to the Analyze workspace.

16.	 To save the fused volume, choose File > Save Fused; the fused volume 
can be saved to disk or to the Analyze workspace (figure 3).

17.	 Close the 3-D Voxel Registration module before proceeding to the next 
exercise.

Figure 2

Figure 3

Exercise 50
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3D Non-Rigid Registration Exercise 51

Non-rigid registration allows for non-linear deformation in the registration transformation between volumes. This exercise will demonstrate how to 
use the 3D Non-Rigid Registration module.

1.	 Load both the Heart_Time_Point_1.avw and Heart_Time_Point_2.
avw data sets from the C:\BIR\images\TutorialData directory.

2.	 In the Analyze workspace, first select the Heart_Time_Point_1 
data set. Then, while holding down <Ctrl> select the Heart_Time_
Point_2 data set (resulting in both being selected).

3.	 Open the 3-D Non-Rigid Registration module (Register > 3-D 
Non-rigid).

4.	 Choose File > Input/Output Ports to ensure that Heart_Time_
Point_1 is assigned as the ‘Base Volume’ and Heart_Time_Point_2 is 
assigned as the ‘Match Volume’ (figure 1).

5.	 To open the Cursor Link tool (figure 2), select Tools > Cursor Link. 
The cursor link will allow you to interactively review the data.

6.	 To change the orientation, open View > Orientation, select 
Coronal. To change the size of the data, select View > Size.

7.	 To set a blend mode, right click in the top-right display pane. 
Use the Section slider to navigate through the data.

Figure 2

Figure 1
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8.	 Open the Generate > 3D Non-Rigid NMI window. This window gives 
the following options:

•	 Threshold: specifies the clip values applied to the volumes before 
attempting registration. Check the Show Thresholding option and 
note the update in the Cursor Link image display as you adjust the 
threshold range, only voxels displayed in white will be considered 
for registration.

•	 Minimum Region Size: specifies the scales at which the 
registration is conducted.

•	 Samples: defines the number of samples used in each region for 
which the Mutual Information cost function is evaluated.

•	 Process: sets limits of confidence for the registration.

•	 Minimum Entropy: specifies the minimum histogram entropy in a 
subregion in order to be registered. 

•	 Minimum NMI: specifies the minimum NMI value for a registration 
result to be considered valid.

9.	 Once you have defined your parameters in the 3D Non-Rigid NMI 
window, click Register to initiate the non-rigid registration process.

10.	 Once the registration is complete, review in the Cursor Link tool 
(figure 3).

11.	 To output the transformed match volume to the Analyze Workspace, 
select Generate > Transform.

3D Non-Rigid Registration Exercise 51
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12.	 Use the Volume Compare module to compare the original Heart_Time_Point_1 and Heart_Time_Point_2 data sets  
(figure 4). Then compare the original Heart_Time_Point_1 and the transformed Heart_Time_Point_2 data set (figure 5).

3D Non-Rigid Registration

Figure 4 Figure 5

Exercise 51
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Measurement
Analyze 12.0: Essential Training Guide
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Line Profile: Intensity-based Line Measurement Exercise 52

The Line Profile module enables calculation of image intensities along straight lines and freehand traces. Coordinate points and angle

measurements can also be made. All measurements can be logged and saved to disk.

1.	 Load the MRI_3D_Head.avw data set from the $:\BIR\images\TutorialData 
directory.

2.	 Open the Line Profile module (Measure > Line Profile).

3.	 Use the slice slider to move to slice 97.

4.	 To calculate the intensity values along a straight line in this slice, select the Line 
tool in the main Line Profile window (figure 1).

5.	 Position the cursor on the image and click to begin drawing. The Sequence 
window (Generate > Sequence) provides X and Y coordinate slider bars for 
precise positioning of lines.

6.	 The Profile window (figure 2) will automatically 
be returned when a line is drawn, displaying the 
intensity profile of the line. The Profile window 
allows profiles, statistics, distances, and FWHM 
(full width half max) measurements to be 
logged.

7.	 Click Log Profile in the Profile window. To save the Line Profile Log 
as a .stats file for use in another application (such as Microsoft Excel), 
select Save in the Log window.

8.	 Select the Trace tool in the main Line Profile window to draw a 
freehand trace.

9.	 Select the Caliper tool (figure 3), an Angle Measure window will 
automatically be returned. The Caliper tool provides a series of 
repositionable points and lines, enabling measurement of user-specified 
angles and distances on a selected slice. The Angle Measure window 
will automatically update with any repositions.

10.	 Close the Line Profile module before proceeding to the Additional Task.

Figure 1

Figure 2 Figure 3

note To log FWHM, open the 
Profile Options window 
(Generate > Profile) and set 
‘Full Width Half Max’ to ‘On’.

tip If a structure of interest is in another orientation, choose Generate > Orientation to choose between transverse, coronal, 
and sagittal orientations, or define your own oblique orientation.
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Line Profile: Radial Sequence Tool

Figure 4

Figure 5

Exercise 52.1

1.	 The Radial Sequence tool in the Line Profile module 
enables users to sample a radial sequence of profiles.

2.	 Load the VH_Abdomen.avw data set from the $:\BIR\
images\TutorialData directory.

3.	 Open the Line Profile module (Measure > Line Profile).

4.	 Open the Profile Options window (Generate > Profile) and 
set Full Width Half Max to On.

5.	 Select the Line tool and then draw a line starting in the 
middle of the right femur, finishing outside (figure 3).

6.	 Open the Radial Sequence tool (Generate > Radial 
Sequence).

7.	 Set the Angle Increment to 10. When sampling a radial 
sequence the angle is incremented until a full 360 degrees 
from the starting position has been sampled.

8.	 Set Log Profile, Log Stats, and Log FWHM to On.

9.	 Click Sample Radial Sequence.

10.	 When the process has run, a Stats Log, Profile Log, and 
FWHM Log (figure 5) will be returned. To save any of the log 
files, right click and select Save Log.

11.	 Close the Line Profile module before proceeding to the next 
exercise.
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Region of Interest: Defining Regions Exercise 53

The Region of Interest module allows users to define and measure 3-D regions. This exercise will demonstrate how to use the tools in the module 
to define regions of interest within a volume image.

1.	 Load the MRI_3D_Head.avw data set from the $:\BIR\images\
TutorialData directory.

2.	 Open Region of Interest (Measure > Region of Interest).

ROI Interface

3.	 When the module is opened, an object map is automatically created 
to store defined regions. To define a new region, make sure that the 
Object to Define: is set to ***New*** at the bottom of the window 
(figure 1).

4.	 The buttons along the left side of the window control the definition 
of regions on the images (figure 2). The buttons below the image 
display allow you to modify the defined regions (figure 3).

5.	 The first slice of the volume is automatically displayed when the ROI module is 
opened. You can move to a different slice by using the Slice slider bar or + and - on 
your keyboard. The currently displayed slice number and orientation can always be 
seen in the lower left corner of the image display.

Rectangle Tool

6.	 Define a rectangular region on slice 1 using the Rectangle tool. Position the cursor 
on the image display, then, click and drag the cursor out to size the rectangle, when 
you release the mouse button the new region ‘1.Object’ will be created and added to 
the object map (figure 4).

7.	 Copy the region to the next slice (slice 2) by pressing the Copy Regions Forward 
PowerBar button once.

8.	 Regions can be modified using the buttons found below the image display. Select the 
Move button. Position the cursor near the region you wish to modify, then click and 
drag the cursor; any movement of the cursor will move the region. Also try using the 
Rotate and Scale buttons (found directly to the right of the Move button).

Figure 1

Figure 4

Figure 3

Figure 2

tip Holding the 
<Ctrl> key 
while sizing 
will force a 
square.
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Oval Tool

9.	 Add a new region to slice 2 using the Oval tool (figure 5).

10.	 Press Copy Regions Forward to copy the regions to slice 3.

11.	 Select the Move button again. To move all regions on a slice simultaneously, hold the <Ctrl> 
key while moving the regions as described in step 8. When you release the mouse button, a 
dialog box will be returned asking if you would like to ‘Move Regions in: This Slice Only, the 
Entire Object Map, or Cancel the move’, click This Slice Only.

12.	 Move to slice 4.

Polygon Tool

13.	 There are currently no regions defined on slice 4, define a region on slice 4 using the Polygon 
tool.

14.	 To begin defining the polygonal region, position the cursor on the image display and click 
once to set a starting point. Move the cursor outward to specify the length and direction of the 
first polygon side. To set a vertex and begin drawing another side, click once. Double-click to 
close the polygon (figure 6).

15.	 If after defining the region it is unsatisfactory, click the Undo button.

16.	 Move to slice 5.

Manual Trace Tool

17.	 Define a region on slice 5 using the Manual Trace tool. Position your cursor on the image 
display, then click and hold the mouse button to begin drawing the trace, release the mouse 
button to end the trace. The last point of the trace will be automatically connected to the first 
point of the trace.

Figure 5

Figure 6

Region of Interest: Defining Regions Exercise 53
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Region of Interest: Defining Regions
18.	 If you make a mistake while tracing, continue holding the mouse button 

down, and press the <u> keyboard key. The trace will slowly back up from 
the current position until the <u> key is released. Try this by drawing a line 
on the image, and while continuing to hold the mouse button down, press 
the <u> key. Once the trace has backed up half way, release the <u> key 
and continue your trace in a different direction.

19.	 To define a region without having to continuously hold down the mouse 
button, right-click on the image display and choose the Button Passive 
option. When ‘Button Passive’ is selected, simply click on the image 
display to begin the trace, and then click again when you are ready to end 
the trace and define the region. The ‘Button Passive’ option is available 
for all region definition tools.

20.	 Right-click and deselect the Button Passive option. Then, click Clear 
Regions on the left side of the window to clear all regions defined on this 
slice.

21.	 With the Manual Trace tool still selected, check the Smart Edge option. 
The ‘Smart Edge’ option searches for edges (areas of high gradient) 
when drawing a trace with the Manual Trace or Spline tools. Click once 
to begin a trace along an edge in the image display, letting ‘Smart Edge’ 
determine the path, click again to lock that portion of the trace. When 
the region of interest has been defined, double-click to end the trace. 
Uncheck the Smart Edge option.

22.	 Move to slice 6.

Spline Tool

23.	 Define a new region on slice 6 using the Spline tool. The Spline tool 
enables the drawing of splines with moveable control points. Position the 
cursor on the image display and click once to begin drawing a spline, click 
once again to set a control point. When the region of interest has been 
defined, double-click to close the spline.

24.	 To modify the region with the spline control points, select the Move button 
and then drag any control point to a new location.

Figure 7

Exercise 53
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Region of Interest: Intersecting Regions
1.	 When objects overlap, the resulting regions may not appear as expected. 

Since the object map is a one-to-one mapping of the voxels to an object, 
a voxel cannot be part of more than one object. The ‘Intersections 
become part of:’ option (in the lower left hand corner) allows you to 
control how intersecting regions are handled.

2.	 Move to slice 7.

3.	 Choose File > Reset Object Map to clear all regions from the volume. In 
the dialog box returned, click Continue without Saving.

4.	 Ensure that Intersections become part of: is set to Defined (figure 8).

5.	 Select the Rectangle tool and define a region.

6.	 Now, select the Oval tool and define a region that overlaps the rectangle.

7.	 The intersecting area becomes part of the region being defined, 2.Object 
(figure 8).

8.	 Click Undo button and then set Intersections become part of: to 
Existing.

9.	 Select the Oval tool and again define a region that overlaps the rectangle.

10.	 The intersecting area now becomes part of the existing region, 1.Object 
(figure 9).

11.	 Click Undo and then set Intersections become part of: to New.

12.	 Select the Oval tool and again define a region that overlaps the rectangle.

13.	 The intersecting area now becomes a new region, 3.Object (figure 10).

14.	 Close the Region of Interest module before proceeding to the next 
exercise.

Figure 8

Figure 9 Figure 10

Exercise 53.1



Analyze 12.0 Training Guide 132

Region of Interest: Defining Regions Exercise 54

This exercise will demonstrate how to use more advance region definition tools in the Region of Interest module to define objects of interest within 
a 3-D volume image. The exercise will also show you how to measure these objects.

1.	 Load the MRI_3D_Head.avw data set from the $:\BIR\images\TutorialData 
directory. 

2.	 Open the Region of Interest module (Measure > Region of Interest).

3.	 Using the slice slider below the image display, move to Slice 122.

4.	 In the main ROI window, select the Auto Trace tool.

5.	 Position the cursor near the center of the brain and click to set a seed point. The 
ROI window will automatically update once a seed point is set to display a double-
ended slider bar (to specify a threshold range) and other Auto Trace parameters 
(figure 1).

6.	 Use the double-ended slider bar to set the threshold minimum to 34 and the 
threshold maximum to 129. Then, click Apply. The double-ended slider bar will 
disappear and the new region will be named ‘1.Object’.

7.	 Press the Copy Regions Forward PowerBar button once. The auto trace will be 
copied to the next slice. Notice that the auto trace is recalculated for each slice 
based on the set threshold range.

8.	 Press Copy Regions Forward until the auto trace has been applied to all the 
remaining slices containing brain matter, (until approximately slice 181).

9.	 Once you have copied the region forward to the remaining slices, choose Tools > 
Show Rendering to open the Render Tool and view a  
3-D rendering of the defined object (figure 2). Click Done 
to dismiss the window.

10.	 Open the Objects window (View > Objects). Select 
Object.1 from the Object drop-down menu and change 
Name of Object.1 to Brain. Click Done to dismiss the 
window.

Figure 3

Figure 1

tip If you placed your seed point towards the 
outside of the brain, it will eventually be
copied forward to an area of a slice that 
does not contain the brain. Select the 
‘Move’ button and move the seed point 
to the middle of the  brain, then, continue 
to copy the region forward. To learn more 
about editing regions see the Additional
Task at the end of the exercise.
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Measuring Regions

11.	 Open the Sample Options window (Generate > Sample Options).

12.	 In the Sample Options window set the following (figure 3):

•	 Sample Type: Object(s), check the Brain object

•	 Summing: On

•	 Sample: All Slices

•	 Sequence Display: Off

•	 Log Stats: On

13.	 Click Configure Log Stats to open the ROI Stats window. The ROI Stats window 
displays all statistics that can be returned for the ‘Stat Type’ selected in the Sample 
Options window (in this case the ‘Intensity’ Stat Type). All statistics with a check 
mark in the ‘Log’ box to the left will be reported in the ROI Stat Log when the defined 
object is sampled.

14.	 Click Sample Images. The module will now sample the defined object (‘Brain’).

15.	 The ROI Stat Log will automatically be returned, displaying the object statistics (figure 
4). Click Done; in the dialog box returned click Discard, then Exit.

16.	 In the Sample Options window switch Summing to Off and 
Sequence Display to On.

17.	 Click Sample Images to sample the object again. This time 
each slice will be displayed as it is sampled as ‘Sequence 
Display’ is now set to ‘On’. Notice the difference in time taken 
to sample the entire volume. The object statistics for each 
slice will be reported in the ROI Stat Log, as ‘Summary’ is set 
to ‘Off’.

Figure 4

Figure 5

Region of Interest: Defining Regions Exercise 54
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1.	 Using the Show Next and Show Previous Slice PowerBar buttons, review the ‘Brain’ 
object (defined previously) slice-by-slice to determine if the auto trace leaked into 
other structures.

2.	 On slices where the auto trace leaked, select the Edit Region button and draw in the 
edge of the brain where the leak occurred. Areas beyond that edge will be removed 
from the object on that slice.

3.	 Next, use the slice slider below the image and move to slice 62.

4.	 Ensure that the Object to Define is set to Brain (at the bottom of the ROI window). 
Then, trace the brain on slices 62-121 using the Auto Trace or another region 
definition tool.

5.	 Once you have traced the ‘Brain’ object on slices 66-121, choose Tools > Show 
Rendering to open the Render Tool and view a 3-D rendering of the define object 
(figure 1). Click Done to dismiss the window.

6.	 Open the Sample Options window (Generate > Sample Options) and set Summing 
back to On and Sample to All Slices.

7.	 Click Sample Images in the main ROI window to sample the ‘Brain’ object as it is 
defined on slices 66-181.

8.	 Choose File > Save Object Map to save the object map with the ‘Brain’ object.

9.	 Close the Region of Interest module before proceeding to the next exercise.

Figure 1

Region of Interest: Editing Regions Exercise 54.1
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Region of Interest: Measuring Regions Exercise 55

As well as allowing users to define and measure objects defined in the module the Region of Interest module also allows users to load and 
measure object maps created in other modules.

1.	 Load the MRI_3D_Head.avw data set from the $:\BIR\images\TutorialData 
directory. The data set may be available in the Analyze workspace if you have 
completed exercise 45 or 46.

2.	 Open the Region of Interest module (Measure > Region of Interest).

3.	 Choose File > Load Object Map and load the MRI_3D_Head.obj object map from 
the $:\BIR\images\TutorialData directory.

4.	 Open the Objects window (View > Objects) and set Control by to Attribute.

5.	 Notice that this object map contains several objects. With the Display attribute 
selected, switch the Lenticular and Caudate objects to On.

6.	 Using the slice slider below the image display, navigate through the volume, the 
objects with the ‘Display’ attribute set to ‘On’ will be seen on the images (figure 1).

7.	 Open the Sample Options window (Generate > Sample Options).

8.	 In the Sample Options window set the following:

•	 Sample Type: Object(s), check Brain

•	 Summing: On

•	 Sample: All Slices

•	 Sequence Display: Off

•	 Log Stats: On

9.	 Click the Sample Images button to sample the ‘Brain’ object.

10.	 The ROI Stat Log will automatically be returned, displaying the object 
statistics (figure 2). Note the volume given is only for the ‘Brain’ object, not 
the entire brain. To find the total volume of the brain you need to obtain 
the volume of the objects that make up the brain – in this exercise this 
includes the ‘Brain’, ‘Ventricle’, ‘Lenticular’, and ‘Caudate’ objects.

Figure 2

Figure 1
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11.	 Click Done to close the ROI Stat Log; in the dialog box returned 
click Discard, then Exit.

12.	 In the Sample Options window, check the Ventricle, Lenticular, 
and Caudate objects (the ‘Brain’ object should already be 
checked).

13.	 Click Sample Images button. The individual volumes for each 
object will be returned to the ROI Stat Log. The sum of these 
volumes is the total brain volume.

14.	 To have the volume of the objects added together automatically for 
the total volume, set Combine Objects to Yes under the  
selection area.

15.	 Click Sample Images. The total brain 
volume will now be returned to the 
ROI Stat Log (figure 4).

16.	 Save the .stats file. 

Figure 3

Region of Interest: Measuring Regions Exercise 55
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Region of Interest: Histogram Analysis Exercise 56

This exercise will provide instructions on how to generate a histogram for an individual slice within a volume, an entire volume, and for a 
defined object.

Sampling a Single Slice

1.	 Load the MRI_3D_Head.avw data set from the $:\BIR\images\
TutorialData directory.

2.	 Open the Region of Interest module (Measure > Region of 
Interest).

3.	 Use the slice slider directly below the image, and move to slice 97.

4.	 Open the Histograms window (Generate > Histograms).

5.	 In the Histograms window, set Histogram Display to On and set 
Log Histogram to On.

6.	 In the main ROI window click on the image. The module will sample 
voxel intensity vs. occurrences. The results will be displayed as a 
histogram and saved to a Histogram Log file. The Histogram Log file 
can be saved by right-clicking in it and selecting Save Log.

7.	 Close all windows associated with the ROI module.

Figure 2

Figure 3

Figure 1
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Region of Interest: Histogram Analysis Exercise 56

Sampling a Volume

1.	 Select the MRI_3D_Head.avw data set and open the Region of 
Interest module (Measure > Region of Interest).

2.	 In the Histograms window, set Histogram Display to On and set 
Log Histogram to On.

3.	 Next open the Sample Options window (Generate > Sample 
Options).

4.	 In the Sample Options window, set Summing to On and set Sample 
to All Slices (figure 4).

5.	 In the main ROI window click on the image display to start the 
sampling process. The module will sample voxel intensity vs. 
occurrences for the entire volume. The results will be displayed 
as a histogram and saved to a Histogram Log file (figure 5). The 
Histogram Log file can be saved out of Analyze by right-
clicking in it and selecting Save Log.

6.	 Close all windows associated with the ROI module.

note If you want to sample all slices at the same time, but do not want
to ‘sum’ the information, simply set Summing to Off, intensity vs.
occurrence will be reported for each individual slice in the volume.
For a quicker sampling time, set Sequence Display to Off.

Figure 5

Figure 4
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Region of Interest: Histogram Analysis Exercise 56

Sampling an Object

1.	 Select the MRI_3D_Head.avw data set and open the Region of 
Interest module (Measure > Region of Interest).

2.	 Select File > Load Object Map and load the MRI_3D_Head.obj 
from the $:\BIR\images\TutorialData directory.

3.	 Open the Histograms window (Generate > Histograms).

4.	 In the Histograms window, set Histogram Display to On and set 
Log Histogram to On.

5.	 In the Sample Options window set the following (figure 7):

•	 Sample Type: Object(s)

•	 Check only the Brain object

•	 Summing: On

•	 Sample: All Slices

6.	 Click on the Sample Images button to start the sampling 
process. The module will sample voxel intensity vs. 
occurrences for the brain object. The results will be 
displayed as a histogram, and also saved to a Histogram 
Log file (figure 7). The Histogram Log file can be saved 
out of Analyze by right-clicking in it and selecting Save 
Log.

7.	 Close all windows associated with the ROI module.

Figure 7

Figure 6
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Importing .stats files into Excel Exercise 57

ROI Stat Log files (.stats) and Histogram Log files (.hst) can be saved out of Analyze as text files. These text files can be imported into third party 
statistical applications such as Excel, for further statistical analysis. This exercise will demonstrate how to load a .stats file into Excel. Note that the 
process for loading a .hst file is identical.

1.	 Open Excel, then select File > Open.

2.	 In the Open window, select All Files (*.*) from the File Type 
drop menu.

3.	 Navigate to and open the .stats file.

4.	 The Text Import Wizard will appear.

5.	 In Step 1 of 3 Under Original Data Type select Delimited 
and click Next at the bottom of the screen.

6.	 In Step 2 of 3 of the Text Import Wizard, under the 
Delimiters select Space, and deselect any other options. 
Then click Next.

7.	 In Step 3 of 3, in the Data Preview section, simply click 
Finish at the bottom of the screen. Your stats file will now 
appear in an excel worksheet.
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Stereology: Estimating Volume Exercise 58

The Stereology module estimates volume and surface area using the stereological method of point counting. The point counting method consists 
of overlaying the images entirely with a randomly positioned and oriented systematic array of test points and counting the number of occasions on 
which a point lies within the feature of interest.

1.	 Load the Canine_Chest_CT.avw data set from the $:\BIR\images\
TutorialData directory.

2.	 Open the Stereology module (Measure > Stereology).

3.	 The intensity scaling of the images must be changed so that they are viewable. 
Open the Intensities window (View > Intensities) and change the Maximum to 
145. Click Done to dismiss the window.

4.	 Open the Grid Parameters window (Generate > Grid) to set up a sampling grid 
that encompasses the heart (figure 1).

5.	 The heart first appears around slice 42 and remains visible until slice 94. Set the 
Starting Grid Slice to 42. Using Stereology, it is not necessary to sample every 
slice, set the Grid Slide Increment to 3 and Number of Grid Slices to 17.

6.	 Click Generate Grid. Then, click Done to dismiss the Grid Parameters 
window.

7.	 In the main Stereology window, click in the image display and drag your 
cursor over all grid points that lie on the heart (figure 2). If points that are not 
on the heart are mistakenly selected, hold <Shift>, click and drag the cursor 
over to deselect them.

8.	 When you are finished selecting points on the current slice, press the Next 
Slice PowerBar button to move to the next grid slice (specified earlier in the 
‘Grid Slice Increment’ field) and select the appropriate points. Continue in 
this manner until all grid slices have been examined.

9.	 Open the Statistics window (Generate > Statistics) to view the estimated 
volume of the heart.

10.	 Close the Stereology module before proceeding to the next exercise.
Figure 2

Figure 1

note Any name can be chosen for the local database, however when creating multiple data-
bases, following a coherent naming convention will simplify database management.
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Object Counter: Counting  Cells Exercise 59

The Object Counter module allows a user to count the number of objects that occur on each slice of a loaded data set. The goal of this exercise is 
to count and measure cells from light microscopy data. 

1.	 Load the FatCells.avw data set from the $:\BIR\images\TutorialData directory.

2.	 Open the Object Counter module (Measure > Object Counter).

3.	 Select the PreProcess tab. This tab allows for correction of intensity fall off near the 
edges of the image data by applying an Inhomogeneity Correction filter. Using the 
default settings, click Apply.

4.	 Select the Connect tab. This tab (figure 1) allows for the specification of region 
growing parameters used to segment objects, including whether the objects should 
be segmented in 2D or 3D (for this exercise, we will use 2D).

5.	 With 2D selected, set the following ‘Connect’ tab parameters:

•	 Max. Size: 3217

•	 Min. Size: 50

•	 Threshold Minimum: 106 (this will allow the cells to be separated from the 
background)

6.	 Click Apply. All of the objects satisfying the size and threshold criteria will be 
identified and outlined in red on each slice of the volume.

7.	 Use the Slice slider bar to move through the slices in the data set. Return to slice 1 
before proceeding to the next step.

8.	 Select the Limits tab. This tab allows interactive screening of segmented objects 
based on position and shape characteristics.

9.	 With the Position button selected, increase the Y Min to 11 using the arrow key 
found to the right. This will cause any objects with a Y coordinate less than 11 
to be removed (objects along the bottom of the image display in the transverse 
orientation).

Figure 1

note The ‘Max’ and ‘Min Size’ parameters can be set by selecting the Interactive Size buttons next 
their respective text entry fields. Specify each by selecting either button and then drawing an 
ellipse around the largest/smallest object to be counted. Hold <Ctrl> while tracing forces the 
ellipse to be a circle.
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10.	 Reduce the X Max to 470 using the arrow key and observe the effect (seen 
along the right side of the image display).

11.	 By default, no shape screening is performed on the objects. Select the 
Circularity button, and check the Restrict Circularity option. Using the slider 
bar set the Circularity Maximum to 1.8.

12.	 Experiment with the effects of restricting Intensity, Diameter, Area, Perimeter, 
and Rectangularity.

13.	 Select the Edit tab. This tab allows objects to be added, deleted, and 
modified manually.

14.	 Select the Measure tab. This tab allows specification of the measurement 
statistics to be returned in the Object Counter Stats window.

15.	 To obtain a cell count on each slice click Log Measurements (without 
checking any of the options). The Object Counter Stats window will be 
returned, displaying a cell count for each slice (figure 2). Click Done to 
dismiss the window.

16.	 In the main Object Counter window select the Measure tab again. 
Check Area and then click Log Measurements. The Object Counter 
Stats window will be returned, displaying an object count for each slice 
and the average area of the objects on each slice.

17.	 To view the area for each individual object, select the Detailed option 
at the bottom of the Object Counter Stats window. When the ‘Detailed’ 
option is selected, click on any object in the Object Counter Stats 
window to highlight the object in the image display or vice versa  
(figure 3).

18.	 Experiment with other measurements available in the Measure tab.

19.	 Close the Object Counter module before proceeding to the next 
exercise.

Figure 2

Figure 3

Object Counter: Counting Cells

tip To save the Object Counter Stats as a .stats file for use in another application 
(such as Microsoft Excel), right-click in the window and select Save Log.

Exercise 59
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Tree Analysis Exercise 60

The Tree Analysis module allows users to take an in-depth look at tree-like structures in medical images, such as coronary arteries. Branching 
angles, segment lengths, and cross sectional areas can all be measured with the module. This exercise will demonstrate how to use Tree Analysis 
to create, review, and sample a coronary tree.

Tree Generation

1.	 Load the Coronary_CT.avw data set from the $:\BIR\images\TutorialData 
directory.

2.	 Open the Tree Analysis module (Measure > Tree Analysis).

3.	 Open the Slice window (Generate > Slice) and set Slice to 64.

4.	 Open the Generate Tree window (Generate > Generate Tree).

5.	 Set the Threshold Minimum to 130 and Maximum to 255.

6.	 Since the thinning algorithm used in the tree generation process is sensitive 
to holes within structures it is advised that the Fill Holes option always be left 
checked.

7.	 Leave the Shortest Skeleton Branch and the Maximum/Minimum Tree Length fields 
as their defaults.

8.	 Set the Approximate Root Location values to X: 56, Y: 69, Z: 125. Note that you can 
also set the Approximate Root Location by clicking in the main module window.

9.	 Click Generate Tree. The Tree Plot window will automatically be returned when the 
extraction is complete. The Tree Plot window can be used to view the trees generated 
and provides a number of tools for in-depth analysis of the structures.

Tree Display Options

10.	 To view the trees generated in the extraction process, use the Tree drop-down menu in 
the Tree Plot window. Select Tree 2.

11.	 Select all four of the Views buttons to display the left, top, right and bottom views of 
the tree.

12.	 Check Render from the Display options at the bottom of each window. A MIP 
rendering will be displayed behind each view of the trees. Experiment with the different 
Label and Display options. Figure 2

Figure 1
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13.	 Several of the Action options can also be used to manipulate the 
tree display. With Action set to Zoom, click the + and - buttons to 
increase or decrease the tree display size. To magnify a specific 
area in a tree, click and drag a rectangle over the area in any of the 
displayed views.

14.	 Now, set Action to Rotate. Click in any of the views and drag the 
tree to a new rotation angle. 

15.	 To return all views to their default display, right-click on any of the 
views and select Reset.

Tree Manipulation

16.	 A new tree can be added by clicking the New Tree button. With 
Action set to Add Point, construct the new tree by drawing 
branches over the rendering in any of the views. The Add Point 
action can also be used to add branches to an existing tree.

17.	 An entire tree can also be deleted by selecting the Delete Tree 
button. Click Undo to recover deleted trees.

18.	 To only delete branches from a tree, set Action to Delete Branch. 
Click on a branch in any one of the views to delete it, all branches 
below it will also be removed from the tree.

19.	 Set Action to Distance to Root and check the Log option. Click on 
a point in the tree; the distance to the tree root from that point will 
be returned to a Tree Distance Log (figure 3).

20.	 Select Stats at the bottom of the Tree Plot window.

21.	 The Stats Option window returned allows specification of 
parameters used to calculate the various tree statistics (figure 4). 
The location where the resulting stats files are saved can also be set 
in this window. To calculate stats, press the Calculate Stats button.

22.	 The Tree Stats window (figure 5) displays the ‘Summary’ statistics 
for each branch of the tree. Select the ‘Detailed’ option from the 
bottom of the window to view statistics on each of the points in the 
branches.

Figure 3

Figure 4

Figure 5

Tree Analysis Exercise 60
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1.	 Check Internal from the Display options in the Tree Plot window (figure 1).

2.	 Set Action to Select and click on the point in the tree from which you wish to 
begin your fly-through movie. The Renderings window will be returned.

3.	 By default, the Renderings window will display both fly-through sequence 
views: Away from Root on the left and Toward Root on the right (figure 2). 
Preview the sequence using the slider bar.

4.	 To generate the fly-through movie, right-click in the Renderings window and 
from the Sequence sub-menu, specify the direction of movement and the 
viewpoint for the movie. The movie will then automatically be saved to the 
main Analyze workspace and can be viewed with the Movie module  
(Display > Movie).

5.	 Close the Tree Analysis and Movie modules before proceeding to the next 
exercise.

Figure 1

Figure 2

Tree Analysis: Generating a Fly-Through Movie Exercise 60.1
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Apps & Add-Ons
Analyze 12.0: Essential Training Guide
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Exercise 61

Epilepsy Seizure Focus Localization with SISCOM (Subtraction Ictal SPECT CO-registered to MRI) automates the technique for advanced imaging 
of epilepsy patients that was developed with Analyze at the Mayo Foundation. This method uses a combination of SPECT and MRI imaging for 
improved diagnosis of areas of regional activation in the brain during a seizure. The SISCOM technique requires acquisition of ictal (during the 
seizure) and interictal (resting, or between seizures) SPECT images and an MRI volume spanning the entire brain. This exercise will demonstrate 
how to use the SISCOM module within Analyze.

1.	 Load the data sets SISCOM_Ictal_SPECT.avw, SISCOM_Interictal_SPECT.avw, 
and SISCOM_MRI.avw from the $:\BIR\images\TutorialData directory.

2.	 Select the data sets in the following order (hold down the <CTRL> key to select 
multiple data sets, or click using the middle mouse button):

•	 SISCOM_Ictal_SPECT.avw

•	 SISCOM_Interictal_SPECT.avw

•	 SISCOM_MRI.avw 

Note the selection order: Ictal, Interictal, MRI. If the data is not selected in this 
order the SISCOM procedure will fail to run correctly.

3.	 Open the SISCOM module (Apps > SISCOM).

4.	 Open the Register SPECT option (Process > Register SPECT) to compute an 
activation map.

i. 	 Set the Interictal SPECT minimum Cerebral Activity Threshold level to 75.
   	 Note the change in the binary image.
ii. 	 Ensure that the Interictal Transformation Type is set to Linear.
iii. 	Use the Activation Level slider bar to set the standard deviation to 2.0.
iv. 	Next, select the Register and Map button. The Register SPECT tool will
	 automatically register, normalize, subtract, select the statistically 

significantv oxels of activation, and output the activation map based on the 
parameters specified above. Note that the tool will update, displaying the 
Activation Map.

5.	 Select Next to continue onto the next step of the SISCOM procedure, MRI brain 
extraction.

Figure 1

SISCOM (Subtraction Ictal SPECT Co-registered to MRI)
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6.	 The Extract MRI Brain tool allows for segmentation of the 
brain for SPECT-MRI registration.

7.	 Right-click in the MRI data display window and select the 
Intensities option. In the Intensity (MRI) window returned, 
change the Maximum to 100 then click Done to close the 
Intensity Tool.

8.	 Use the slider bar to adjust the minimum and maximum 
threshold values to obtain the best definition of the cortical 
boundary as possible. 

9.	 Select Extract Brain to segment the brain. After segmentation 
is complete, the extracted brain is automatically displayed in 
the Extract MRI Brain tool. The segmentation can be reviewed 
using the Slice slider bar (figure 2).

10.	 Select Next to continue to the next step, registration of the 
SPECT data sets to the MRI data sets.

11.	 The Fuse SPECT & MRI tool will automatically open and 
immediately run the Match Surfaces process, registering the SPECT 
data sets to the MRI data set and displaying the Activation Map 
overlaid on the MRI data set. The activation map and MRI can be 
reviewed using the orthogonal orientation buttons and the slice 
slider bar (figure 3).

12.	 Select Fuse Volumes. The activation map and MRI will be fused 
and automatically be saved to the Analyze workspace. Select Done 
to close the Fuse SPECT & MRI tool. 

Figure 2

Figure  3

SISCOM (Subtraction Ictal SPECT Co-registered to MRI) Exercise 61
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Figure 4

Figure 5

13.	 Select the Compare Tool option (Process > Compare Tool). The 
Compare Tool provides an interface for users to display and visually 
inspect the accuracy of the registration and fusion of the volumes 
created in the SISCOM process. Use the drop down menu options 
under each image to select the volumes to compare (figure 4). Select 
Done when review is complete.

14.	 Select the Create Object Map option from the File menu to generate 
an object map based on the areas of activation.

15.	 Select Output Object Map. The object map will be automatically 
saved to the location specified using the File option. The Render tool 
(figure 5) will automatically open, allowing for interactive review of the 
object map.

16.	 Close all windows related to the SISCOM module before proceeding to 
the next exercise.

SISCOM (Subtraction Ictal SPECT Co-registered to MRI) Exercise 61
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Mayo 3D Brain Atlas Exercise 62

The Analyze Mayo 3D Brain Atlas add-on provides a unique 3D implementation of the Talairach anatomical atlas of the human brain. The Mayo 
3D Brain Atlas add-on allows for 3D navigation of the atlas and interactive query and reporting of atlas-based coordinates in many common 
volumetric and neuroanatomical and neurofunctional frames of reference, including TT, MNI, SPM, FSL and ICBM coordinates. In addition, atlas-
derived neuroanatomical regions can be output from the module and then utilized directly in many other Analyze modules. This exercise will 
demonstrate how to use the Mayo 3D Brain Atlas add-on.

1.	 Load the MRI_3D_Head data set from the C:\BIR\images\TutorialData 
directory.

2.	 Select the MRI_3D_Head data set then open the Mayo 3-D Brain Atlas 
module (Apps > Mayo 3D Brain Atlas).

3.	 The PowerBar buttons in the main Mayo 3D Brain Atlas window are set 
up in the sequence of operations performed. The first step to using the 
atlas is AC-PC based alignment of the loaded image data to the Talairach-
Tournoux coordinate and proportional grid system.

4.	 Open the Align AC-PC window (Tools > Align AC-PC).

5.	 Use your cursor to move the AC and PC points to the appropriate location 
on the sagittal image. Enlarging the image may help to identify the AC and 
PC; right-click on the display and select Size > Double. Note that the left 
and right arrows and rotation buttons can be used to adjust the data set 
to correct for symmetry.

6.	 Select the AC point and move it to the appropriate location. The magnify 
window will automatically display helping you to determine the precise 
location of the AC (figure 1).

7.	 Select the PC point and move it to the appropriate location.

8.	 Select Align AC-PC. The image volume will realign to the AC-PC.

9.	 Select Next to open the Extract Brain Tool. A seed point and threshold 
range are automatically set by the Extract Brain Tool. These can be adjusted 
if necessary.

10.	 Check the Fill Holes after Extraction option and then select Extract Brain.

11.	 The extracted brain can be reviewed using the Slice slider bar (figure 2).

Figure 1

Figure 2
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12.	 Select Next to open the Adjust Registration tool (figure 3). 
If needed the atlas can be adjusted. Right-click in any of the 
orthogonal display panes and select Restrict > None. Note the 
right-click menu also provides options to display the loaded or 
extracted volume and increase the display size.

13.	 The grid can now be manipulated. Move the grid lines in any of 
the orthogonal displays to adjust the atlas. When you are finished 
making adjustments, right-click in any of the orthogonal displays 
and set Restrict back to All.

14.	 Move the yellow square marker in any of the orthogonal displays 
to move through the loaded volume. Note that when the marker 
is moved the name of the atlas region and the coordinates of the 
current marker point will appear in the lower left-hand corner of the 
window.

15.	 To query specific structures by coordinates, navigate back to the 
main module window and select the Query Atlas button from the 
PowerBar.

16.	 The Adjust Registration window and the Query Atlas window 
work together. The Query Atlas window will return the atlas 
structure and coordinates for the current location set in the Adjust 
Registration window.

17.	 In the Adjust Registration window, move the Yellow marker to a 
location you wish to query.

18.	 In the Query Atlas window click the Query button, the structure and 
location of the Yellow marker will be returned.

19.	 Check the Query Range option and set the Range to 5. Click 
the Query button again. All structures with in a 5 voxel range 
will be reported in the query window (figure 4). Please note: The 
information returned can be saved as a text file by right-clicking in 
the Query window and selecting the Save As option.

20.	 Close the Query Atlas and Adjust Registration windows.

Figure 3

Figure 4

Mayo 3D Brain Atlas Exercise 62
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21.	 To save the atlas as an object map open the Generate Output 
window by clicking on the Output button in the PowerBar. 

22.	 In the Generate Output window returned (figure 5), make sure the 
following options are set:

i. Set Output What to Specified Atlas
ii. Set Space to Original Volume
iii. Set Which Atlas to Transverse
iv. Set Output As to Object Map

23.	 Next change Object(s) to Specified and then click on the List 
button. The Object List window returned allows you to select only 
the objects you wish to output to the object map, click Done to 
close the window and then set Object(s) back to All.

24.	 Select Generate Output. The object map will be saved as 
‘AtlasOutput_MRI_3D_Head.obj’ in the specified directory.

25.	 Select Done in the Generate Output window and close the Mayo 3D 
Brain Atlas.

26.	 To review the Atlas object map created, select the MRI_3D_Head 
data set from the Analyze workplace and then open the Multiplanar 
sections module. Select File > Load Object Map and load the 
object map saved in step 23. Select the Traffic Signal icon to begin 
the sequence display of the data.

27.	 Close all windows before proceeding to the next exercise.

Figure 5

Mayo 3D Brain Atlas Exercise 62
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Diffusion Tensor Imaging (DTI) Exercise 63

The Analyze MR Diffusion Tensor Imaging add-on computes and saves the primary diffusion maps from diffusion-encoded MRI data. The module 
also provides standard visualizations of DTI data and includes white fiber tracking and visualization (Tractography). This protocol will demonstrate 
how to compute DTI maps as well as compute and display fibers.

Loading DTI data and Computing DTI Maps

1.	 To load in a series of DTI data open the DICOM Tool (File 
> DICOM Tool), then import the DICOM images (File > 
Import Dicom Images). Navigate to the folder containing 
the DTI data, and click OK. A dialogue window will be 
returned asking if you would like to import all DICOM files 
found below that directory, click Yes.

2.	 Select all the DTI files and click Load Volume. In 
the dialogue window returned, select Create a 4D 
Multivolume.

3.	 Once the volumes are loaded into the workspace, select 
the appended multivolume (Figure 1).

4.	 Open the DTI module (Apps > DTI), the module will open 
to the Config tab (figure 2).

5.	 Analyze will attempt to automatically load the gradient 
directions. If the gradient directions are not automatically 
loaded, click the Load Gradient Directions button and 
select a text file with the gradient directions already logged.

6.	 The data may require a flip along an axis.

7.	 Select the Map Processing tab.

8.	 Set a threshold so the background noise is set to white, 
any voxels displayed in white will not have map values 
computed (figure 3). Click Compute DTI Maps.

Figure 2

Figure 3

Figure 1
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9.	 After the DTI Maps have been computed, select File > Save DTI 
Maps. In the window returned, set the Destination to Analyze 
Workspace and click Save Volume.

10.	 All the DTI Maps will be output to the Analyze workspace.

11.	 To define a region of interest, select the FA map and the EVCM. 
Open the Region of Interest module (Measure > Region of 
Interest).

12.	 By moving the slice slider bar, select a slice that contains a region 
of interest. In this example, we will define the corpus callosum.

13.	 To begin defining, select the Auto Trace tool and set a seed point 
within the corpus callosum. A doubled ended threshold bar will be 
returned in the ROI window.

14.	 For this example, we set the Minimum Threshold to 143 and a 
Maximum Threshold of 237. Click Apply to define this trace as an 
object. 

15.	 Next, we will move to the next slice and set another object for the 
corpus callosum. Click to set a seed point within the region, and the 
threshold previously set should be automatically populated.

16.	 Click Apply to create a second object.

17.	 Now that there are multiple objects defined, save the object map 
(File > Save Object Map).

Diffusion Tensor Imaging (DTI)

Figure 4

Exercise 63
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Diffusion Tensor Imaging (DTI)
18.	 Return to the DTI module and click on the Fiber Tracking tab. Click 

the Load Object Map button. Select the object map from the last 
section, and click Open. The two objects defined in the last section 
will be displayed.

19.	 Click the Compute Fibers button. Once the computation is 
complete, click the Display Fibers button.

20.	 In the display window, the fiber bundles are displayed (figure 5). You 
will see the fibers displayed in the object color they were assigned 
in the Region of Interest module. To zoom in or out on fiber bundles, 
hold the middle mouse button while moving the mouse forwards 
and backwards.

21.	 To rotate the fiber bundles, hold the left mouse button and move in 
the direction you wish to rotate.

22.	 To move the bundles within the window, hold the right mouse 
button and drag the bundles around the window.

23.	 To change the opacity of the image data, use the Opacity slider bar 
just below the window containing the fiber bundles.

24.	 Now under the Boolean Operator, select AND. Click Display 
Fibers. This operation will just show the fibers that are connected to 
Object 1 AND Object 2. The metrics of these fibers can be logged 
by clicking Log Displayed Fiber Metrics.

25.	 You can save these metrics out by clicking Save in the window 
returned. These metrics can then be imported into an excel 
spreadsheet.

Figure 5

Exercise 63
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T2 Projection Exercise 64

The MRI T2 Optimization Add-On provides the ability to enhance the relative contrast between different tissue types in T2 weighted MR images 
postacquistion. The add-on uses a piecewise non-linear intensity transformation based on prior knowledge. The prior knowledge is derived 
from training multiple post-processed data sets acquired at different relaxation (TR) and echo (TE) times. The transformation does not make any 
assumption on the pulse sequence parameters associated with the image to be projected. This exercise will demonstrate how to use the add-on 
to enhance a T2 MRI data set.

1.	 Load the MRI_T2.avw data set from the $:\BIR\images\
TutorialData directory.

2.	 Open the T2 Projection add-on (Apps > T2 Projection).

3.	 The input, or pre-enhanced, T2 data is displayed on the left side of 
the window, the post enhanced data is displayed on the right side.

4.	 Click Show Forward, until Slice 15 is displayed.

5.	 The Relaxation Time (TR) can be adjusted by selecting a value 
from the TR (msec) drop-down menu. Select 1800. Note that the 
post-enhanced display updates when a new value is selected.

6.	 Similarly, the Echo Time (TE) can be adjusted by selecting a value 
from the TE (msec) drop-down menu. Select 110.

7.	 To save post-enhanced T2 select the Create Projection button. 
The projection will be saved to the Analyze workspace. Note the 
enhanced images are named according to the TR and TE values 
used. For example MRI_T2_1800-110.

8.	 Close all windows associated with the T2 Projection module before 
proceeding to the next exercise.

Figure 1
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Volume Metrics Exercise 65

The Volume Metrics Add-On provides tools to assess the quality of multiple associated volumes, allowing the creation of a set of statistics based 
on the type of metric chosen. The add-on can be used to assess the similarity of two co-registered three dimensional volumes using 15 parametric 
or 12 non-parametric similarity indices. The add-on can also be used to assess the concordance of different segmentation results with ground 
truth data using 47 popular binary similarity metrics. This exercise will demonstrate how to compute similarity metric values for two related data 
sets. 

Calculating and Logging Metrics

1.	 Load the MRI_3D_Head.avw and the MRI_3D_Brain.avw data 
sets from the $:\BIR\images\TutorialData directory.

2.	 With both volumes selected, open the Volume Metrics module 
(Apps > Volume Metrics). The first volume selected is the input 
volume, the second volume is the comparison volume.

3.	 To calculate all of the statistics for a specific metric option, select 
the Metric Type, then click the Calculate Metrics button. The 
metrics are calculated and displayed next to each Similarity Value.

4.	 To log the metrics in a log file, click on the Log Metrics button.

5.	 The Volume Metrics Log (figure 2) contains all of the metrics that 
are checked in the main window. To save the metrics log file to 
disk, right click in the log window and select Save Log.

6.	 Click Done to close the log screen.

Figure 1Figure 2


